Issues with Google Integration

After the new integration update, Google voice integration is super funky. It has come to a point wherein my family wants me to roll back smart devices. First there was duplication of devices, I was able to unlink the older link and resolve that. But when we use voice, google says smartthings device is not connected. After a few minutes the same command works. I thought it was voice issue and checked the command by typing it and even saw the activity log to check what google heard. It was as expected “Turn off Master bedroom”, etc. I thought the issue was the google device but that’s not possible since all home devices(5) were behaving the same.

On the verge of being fed up, since i don’t even know what/where the issue is. Any ideas are really appreciated.

With the new Alexa integration, the new integration duplicated all my devices on the Alexa side, leaving me with 2 of each device; one that worked, and one that didn’t. And I didn’t really know which was which.

I removed both the new integration and the old integration, then went into the Alexa app and deleted all the devices that were coming from SmartThings, as they no longer worked.

Next, I told Alexa to discover my devices and confirmed that she didn’t find anything (as expected since both integrations were unlinked).

Then, I enabled the new Alexa integration and had Alexa discover my devices. That found everything again and all the devices worked.

Perhaps you’re running into a similar issue with the Google integration?

I tried the same and the problems still persist. Its a pain and the issue is occuring for nearly every command using voice.

I have been having the same issue for over a week. I have removed smartthings from google. I even went into my google security settings and removed the 3rd party integration. That fixed the connection for about an hour and then it stopped working again.

Anytime I try to control a smartthing device using google home I get the error that google can’t connect to smarthings. This all started when 1 device stopped working and now everything is broken.

It looks like this is a widespread issue. How many time can Samsung break this product?

Some of my Hue lights show up in the Google Home app twice, I assume this is 1 set from Hue connecting to Google, and the other set from SmartThings (I thought I had avoided linking Hue to Google Home to keep this from happening, but somehow it got linked anyway).

I am having similar issues, though slightly different when trying to control specific lights with my Google speakers. Whenever I say turn on (or off) sun room lights, it says the device has not been set up yet (though it’s actually in there twice). However, if I say turn on/off sun room it works but controls everything in the room, not just the lights. I found yesterday that if I use the word “set”, as in set sun room lights to blue, they seem to work just fine. So to turn them on (or off) I say set sun room lights to 100% (or 0%).

It works, but it’s annoying to have to do it that way. I have only noticed the issue in that one room. I need to experiment to make sure that’s the case, however.