Issues Adding Leviton ZWave DZ6HD Dimmers

I have over 50 Leviton ZWave DZ6HD Dimmers that I am trying to add to a Aeotec Hub v3. Out of about the 50 only 3 added as “local” to the hub and got a Device Network ID. The others show up as “placeholder” devices with no Device Network ID and are shown as “cloud” thus the drivers cannot be changed and they do work slower. This is weird as the 3 that connected correctly are some of the furthest from the hub. I have tried deleting through the IDE login and factory resetting them as they cannot be “excluded” through the normal ZWave exclusion process because they are technically not shown as connected to the hub. I also tried just logging into the IDE and adding my own Device ID and selecting the hub but it says “Access Denied”. Any solution or tricks to get these added correctly.

The IDE is part of the old architecture and doesn’t have all the information about devices added with edge drivers. Anything that says “placeholder“ there may have an accurate or incomplete information, but it should still function fine. And even though it says “cloud“ if it’s using an edge driver it is local. It’s just the IDE that is wrong. so none of that should be an issue for you.

It is surprising that you had any devices still add with the DTH instead of a placeholder, though, if they really are all the same model (and have the same fingerprint) :thinking:

Also note that it is important that you not try to make changes through the IDE to a device that is using “placeholder“ – – that could break the integration altogether. :disappointed_relieved:

As far as devices being slower now… is it possible that one of the devices that didn’t show “placeholder“ was acting as an important repeater in your system?

And here’s some more information on the various utilities that are available for the new architecture so far.

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

I believe you will still be able to do a Z wave exclude through the app, but someone else will have to say for sure. :thinking:


1 Like

Ok then it must be some other issue causing some dimmers to run slower then others.

1 Like

Here’s how to exclude from the app:

I have tried this but it does not remove the dimmer for some reason it just says excluding and then fails.
Since the IDE interface is obsolete is there a login for the Edge interface?

No, Edge doesn’t have an IDE like Groovy did.

The closest you’ll get is a Command Line Interface to look stuff up and view logs.

I know in the Groovy IDE interface you can click on a device and see its route back to the hub. Is this possible with Edge?

It doesn’t appear so.

Here’s what I see in the CLI:

C:\smartthings devices 155 -y
name: aeotec-ms6
deviceManufacturerCode: 0086-0102-0064
manufacturerName: SmartThingsCommunity
deviceModel: 0102-0064

  • id: main
    label: main
    • id: motionSensor
      version: 1
    • id: temperatureMeasurement
      version: 1
    • id: relativeHumidityMeasurement
      version: 1
    • id: illuminanceMeasurement
      version: 1
    • id: ultravioletIndex
      version: 1
    • id: tamperAlert
      version: 1
    • id: battery
      version: 1
    • id: refresh
      version: 1
    • name: MotionSensor
      categoryType: manufacturer
      createTime: ‘2022-08-31T01:15:49.938Z’
      networkId: 4B
      driverId: 42930682-019d-4dbe-8098-760d7afb3c7f
      executingLocally: true
      networkSecurityLevel: ZWAVE_LEGACY_NON_SECURE
      provisioningState: PROVISIONED
      type: ZWAVE
      mnmn: SmartThingsCommunity
      restrictionTier: 0

There’s a discussion about Z-Wave and Zigbee route information not yet being available in the CLI here:

great thanks