Leviton DZPA1 and SmartThings Edge

My last device for transition. With the legacy DTH, the Leviton DZPA1 worked with the standard driver. With the Edge driver installed (Z-Wave Switch), I get an APPLICATION_BUSY anytime I press the button on the device. On the other hand, I can fully control the device using the SmartThings UI.

Any help would be appreciated.

I’m not sure if this edge driver would work but the link is worth a read.

Tried it but have the same issue. Looks like I’ll have to investigate further.

These devices are zwave (non plus) and require Hail support (or polling) to retrieve status. I wouldn’t bother trying to bring them over into Edge.

Replace with one of the Jasco (ge/Honeywell) zwave plus dimmer plugins or the newer model Leviton. Your mesh will thank you.

1 Like

Thanks for advice.

1 Like

My DZPA1 are Zwave plus

They work fine on SmartThings. Only issue is when I try to add them as the specific brand/device (Leviton Z-Wave appliance module) they show up as a switch and use the generic Zwave Switch edge driver. So on the app they use the switch icons (instead of outlet icons) & have a dimmer function slider which I would like to get rid of.

Any advice? Try to update the device firmware?

I have an older unit (not zwave plus) so I can’t help here, sorry