Issue with Yale Real Living Door Lock Codes


#1

Having a problem with just one of my 5 yale door locks. I plan to contact Yale Tech Support tomorrow (they are already closed for the day) but I’ve narrowed down the issue, so I’m wondering if anyone else has run into something like this and maybe has some ideas for me.

Basically, my front door lock is reporting that its being unlocked by “code 99” nomatter what code I use to unlock it. I’ve tried removing it and re-adding it to smart things, I’ve done a factory reset and created new codes, and still it reports code 99 on unlock.

All my other door locks are reporting the proper code when unlocked (they are all yale real living deadbolts.)

When I add a new code, it reports properly “Front Door Lock Added Mom” but when I use the Mom code I just created to unlock, "Front Door Lock Unlocked by “Code 99"”

Is there a way to reset the z-wave unit maybe? It seems like it got reset with the factory reset but maybe there’s a separate way to reset it? Anything else I’m missing or can try? Annoying!

I use webcore to run certain pistons based on who unlocks the front door, and obviously none of them are working because the lock isn’t reporting the proper code.

Any help or insight or things to try would be appreciated!

Thanks


(www.rboyapps.com - Make your home your butler!) #2

Sounds like you may be using an older custom handler.

If you have access to RBoy Apps use this handler that will fix the issue and provide you access to the lock advanced features.

You can also switch to the default ST lock handler “z-Wave lock” and use it with SmartLocks or this app:


#3

I’m using the default z-wave lock handler and have been for a while. All my other locks work fine, and this one was working up until about a month ago when suddenly it stopped working properly.


#4

Now I’m really at a loss.

Yale sent me a new Z-wave Module.

I did a factory reset on the lock, excluded the lock from smart things, set a new master code, included the lock in smart things, set some user codes, and the same problem exists.

Not sure what to do next.


(Giovanni) #5

Hi, I have the exact same problem since they did an update like 2-3 months ago, it was working before, Have you found a solution?


#6

I contacted Smart Things support and they said its a known bug on their end. They wanted some data from my smartthings so I think if you contact them and let them know you’re having the same issue they can use your data to help track down the bug.


#7

Team: Aslo have the same problem. I tried installing another handler " Lock Manager" but I am still having the same problem.

Have you been able to solve your issue?

Jorge


(Giovanni) #8

Hi,
I was able to solve this problem using the RBoy Device Handler. works great, I was afraid it wouldn’t but it was worth the investment. it’s called
Universal Enhanced Z-Wave Lock with Alarm, Notification, RFID, Door Sensor and Advanced Features