Is Sonos support being pulled from SmartThings completely?

Noticed that today when looking for any sort of Sonos Device types & Applications, under my-devices-types or my-SmartApps that everything for Sonos is gone.

I’ve also just opened a ticket with support, and they suggested that some of my recent z-wave and zigbee cloud device control issues are related to Sonos devices causing hub communication issues. They’ve asked me to reduce the number of Sonos devices i have on the hub to see if it helps (I only have 4 speakers).

I’d like to know from the Guys @ SmartThings, if they plan on removing Sonos integration completely, as I bought my Sonos Speakers on the specific compatibility presented via SmartThings, and I’d hate to loose a $1200 investment because I can no longer integrate it with my Home Automation System…

Please be candid and honest on if this is something temporary and you’re wokring with Sonos Directly for a fix, or if this is going to be deprecated out of the SmartThings device ecosystem…

Thank you.


I suggest you use this. I find that it works much better (also for sonos!) then the previous sonos labs integration:

I’m curious for an answer as well. I’ve more or less lost control of my z-wave switches and dimmers and have reduced my 4 Sonos speakers down to one to see if that restores the zwave functionality. Losing the Sonos integration will majorly blow.

HI @bennywy, I use Hub v 1 , 9 Speakers with dlna Media Renderer and my zwave switches, zigbe sensors, zwave door lock, zwave power meter, etc all my things works fine. may be the failure its with the hub v2, could you share your settings?

All of my Sonos SmartApps (and the device) are still present in my environment, however I did notice I had no control over it last night or today.

The SmartApps are present but do not actually function. I have the device on my SmartTiles Dashboard, but clicking Play does not play any music to it.

I will test again tonight after work.

Noticed the same thing here (it didn’t work with my Alexa integration or from a scheduled turn on from ST). Will also look into this and it would be bad if it were broken.

Interesting, my Hub v2 Z-Wave problems started not too longer after I added my 7 Sonos devices to it.

Yeah just noticed mine is broken too. It works from the Smartthings app, but Alexa sees the devices as offline. Tried to unlink from smarthings and still offline. This is on top of my wemo lights that say offline in echo app… Good thing they show up twice as Smartthings device too so can still use

@ule I have a v2 hub, four Sonos speakers, three harmony hubs, couple of Amazon echoes, and several zwave switches, dimmers, motion sensors, and open/close sensors. My setup had been working for months before having issues controlling zwave for the past couple of week.

For whatever reason, reducing my setup from four speakers to one speaker seems to have resolved my zwave control issues. Everything has been working fine since this afternoon after doing so. I think others are having a similar experience.

I have no idea why, but this appears to to be a temporary fix even if not ideal.

Hi @bennywy, Are you using the sonos connect or the MR Connect ? Thanks

SmartThings as per my knowledge is working on a complete re-development of their TTS platform. Obviously there are no time lines for it, but @slagle had confirmed this on a separate thread. Hopefully we will have it soon and will be able to use the SONOS integration with more reliable capabilities.
All we need now is patience… which a lot of us have had with the ST Platform. It is not 100% there, but the wait is slowly but surely paying off…:alarm_clock:


I will take @slagle 's like above as a good sign.

I do wish they wouldn’t have killed it for those of us it worked for still.

For now I can set up everything on LANdroid at least and use the Echo which is in a more central location, but I won’t get my “Night Mode Active” message since it isn’t going to be where my trigger is.

All of my Sonos function (on/off) worked this morning…may have been a blip for me yesterday…

All of my Sonos integration is gone and has been for a few weeks now. Starter with text to speech but I have nothing now :frowning: Put in a ticket, we will see where that lands

Not sure about ST Sonos SmartApps but my custom app appears to be working. So, guess Sonos still lives in ST world.

Jealous… very jealous :frowning:

Then allow me to make a pitch for LANdroid/LANnouncer, which uses the Android TTS and doesn’t require Sonos. :wink:


I get a 404 when I try the link.

For what it’s worth, my six Sonos divices are there. They don’t seem to respond, but they are still showing up under “Smart Things.”

A developer posted in another string that Sonos stuff was pulled until it is fixed because the app was “completely broken.”