SmartThings Community

Is anyone working on Leviton Vizia RF +?


(Jen S) #26

If this were a z wave switch, you would press the top of the switch in, and hold it briefly until the led on the bottom of the switch turns orange/yellow and starts blinking. Release back to normal position and it is in include mode.

You must put the switch into include mode BEFORE telling ST to find the new device. The colored LED will stop blinking and turn green once it is included successfully.


(Simon) #27

I have a house full of Vizia RF+ z wave dimmers that were originally programmed with the Leviton stick and connected an OmniProII. I made the change to ST this week and started adding the Dimmers. Everything was going good until I got to my VRCZ1 “1-Button Zone Controller Virtual Dimming Remote”. I have several of these that I used as a 2-way, where I didn’t have anyway to connect the HV travelers.

I have been able to add the VRCZ1 to ST and it see’s it as a controller, but I can’t figure out how to get it to control the load. Since I had to reset the dimmers to get them to connect to ST, the virtual dimming remotes no longer can control the lights. This has not made the move popular in my household, as you can imagine.

I tried in the automation section, but that device doesn’t show up in anything “buttons to press” switches", etc.

From searching the posts, it looks like you also have these devices. Can you give any advice?


(Jen S) #28

Hi Simon,
Wish I had good news for you. In situations where I had the VRCZ1 installed I had to leave that set of switches programmed by the Leviton stick. I briefly had it sort of working as a 3 way on ST but with very low reliability and much double pressing (with the Big Switch- a retired ST sub app). Overall my experience with ST and any Leviton devices that are controllers has been very poor. They have been talking about fixing this issue for over 3 yrs- I don’t think it’s a priority. In fact this year I pulled the VRCZ1 and replaced the array (my kitchen switches) with insteon. ST doesn’t do Insteon either but Alexa does so my family is happy.
Good luck- hope yr experience is better than mine!


(Jen S) #29

FYI - if you have one of the Lev controllers maybe this:

rastasclayton
ADAM
Jul '15
i think i have got it.

1 you have to reset up your system
2 reset all your switches and remotes
3 start by connecting one of your switches to the ST controller ( i think this starts a new network)
4 reset your programming remote or usb
5 join the ST system with your leviton programming device
6 you can program the rest of your system with the remote or usb and the ST controller auto populates all the switches that you add using the programming device. you still have to go and include all the controllers and switches.

i did have to spend a day reprogramming my entire system but this made the ST hub work with the leviton vizia RF. you can not program the Controllers with the ST hub you have to use the leviton programming device. but it all appears to work,


(Simon) #30

Jen,

Thanks. I will give this a try. If I can’t get it to work I could go the insteon route. The way my house is built, there is no way to run a 2-way HV wire without spending $$$, if at all.


(Jen S) #31

Their are some newer Leviton wifi switches available that will work as
remote 3-ways but no matter how you look at it it’s more $$$. I have had
good experiences with Insteon- they make very solid 3 way switches with no
connecting wires. Are your remote switches wired into the lights they are
controlling? You can use other switches (non controller) that don’t have
state memory but they aren’t great for 3 ways b/c of not having instant
communication connections to the other switch pair. Good luck!


(Simon) #32

I have four 3-ways in my house (using Vizia VRCZ1) that have no connection to the lights they are controlling, purely via z-wave associated to the dimmer that is connected to the light. I don’t mind spending <$100 each to get these to work, because it would be at least thousands each to try and get these connected to the light via 3 way travelers, tearing out drywall, drilling though steel superstructure, etc. and a couple could be impossible to pull off. I thought about the Leviton wifi switches, but wiring diagrams show them connected to the light. If I was sure that a press could control another z-wave dimmer, then I would do it, but hours of research including a phone call to Worthington Distribution and I haven’t been able to confirm it.

I will still try to get the VRCZ1’s to work. I just need to set aside a few hours to reset everything like you descibed, with the risk the other three VRCZ1 3-way’s stop working too.


(Stacy) #33

@simonsays - Please let me know if you have any luck with the scene controllers. I am in the same boat with multiple scene controllers throughout my house. I am a programmer, but I haven’t learned the SmartThings model just yet. I’m also not sure if I’ll have time to devote to trying to build device types. We’ll see…


#34

If these are working with direct Association, then you may be able to get them to work to some extent after adding them to the SmartThings network by using the Z wave tweaker device type handler to set the associations. But you won’t be able to use any manufacturer proprietary features.

If you haven’t used custom code before, it’s pretty straightforward. Basically you just copy it from the author and paste it into your own account. Here’s the FAQ for that process:

The tweaker device type handler lets you expose all of the parameters and settings on a mains powered Z wave device and set its associations. Then once you have it configured the way you want, you just go back to using your every day DTH.

You might also find the technical welcome letter in the community – created wiki helpful since you have a programming background:

http://thingsthataresmart.wiki/index.php?title=Welcome_FAQ


(Stacy) #35

Thanks! I’ll check into this. It looks promising!


(Peter O) #36

While this is a very old thread, it touches on some of the issues I am having getting a Z-wave network to work properly with ST. I have 55 devices, about 1/2 Leviton including 2, and 4 button controllers. Some of these have integrated switches. The rest are dimmers, switches, or outlets that mostly run in slave mode to the controllers. The network has been setup and running using Vizia-RF for 5+ years. Controller buttons are programmed using the Vizia-RF software.

I added a ST controller to this network, it mostly joined and auto-loaded the network devices. Naming them was a pain (the existing name wasn’t loaded into ST) but with first trial/error, and then using the IDE and using the hex code I was I able to name most devices.

But I’m now stuck with roughly 6 slave modules that don’t auto-appear in ST. Adding one manually allowed it to appear on the web and the phone app, but control of the device fails from the app. The Vizia-RF program wants the ST device to be ‘re-included’ for updated information, but unlike most Z-wave devices, there is no physical button that puts the device into pairing mode. I haven’t yet opened the box to see if there is a physical switch inside.

Note that in this setup, Vizia-RF is the master. ST is a slave controller. From reading chats, this seems to be a minority of the setups I’ve seen.

Does anybody have any general advise and tips on how to get the ST device to see missing devices, update it’s status to the master, etc.? No, reprogramming the entire network with the ST as master isn’t an option.

Thanks in advance,
-Peter


#37

Don’t shoot the messenger, but the SmartThings hub just doesn’t play well with others in this regard. It lacks support for some of the advanced controller functions, such as controller shift, that would normally be used in multi controller set ups.

In addition, as you may know, it is up to the secondary to ask for new information about devices from the primary, and SmartThings just doesn’t do that. So it meets the requirements to be certified as a basic Z wave controller, but you’re not going to get the kind of options out of it that you would out of a Z wave-only advanced controller. SmartThings was designed from the beginning as a multiprotocol platform, and they really tried not to rely on protocol – specific Utilities unless absolutely necessary.

SmartThings support even says it is specifically advised against to add the SmartThings hub as a secondary controller to another Z wave network. (like I said, don’t shoot the messenger. :disappointed_relieved:)

SmartThings strongly discourages adding the Hub to another Z-Wave network. We cannot offer support for disconnected Z-Wave devices or the inability to add devices through the Hub as a result of including the Hub into another Z-Wave network.


#38

I just had a separate thought… What are the model numbers of the devices that are not showing up in SmartThings?


(Peter O) #39

Yeah, that is bad news. There is no way a ST hub can manage a complex network, especially one with 12 controllers running scenes throughout the house.

It does seem to be OK sucking up the devices on initial install. It’s just adding devices that’s failing.


(Peter O) #40

It seems that only devices added since the initial ST install are missing. Here are two pics. I have a third in-wall dimmer that is also missing.

-Peter


#41

OK, that’s consistent. The SmartThings hub as a secondary controller does not query the primary for network updates. So the only devices it will know about is the ones which were already connected to the primary at the time that the hub joined the network. If you want to add new Z wave devices after that time, you have to remove the smartthings hub and then re-add it each time after you have added new Z wave devices.

This is one of the main reasons they officially “strongly advise against” trying to use it as a secondary. It’s technically possible, but very primitive. :disappointed_relieved:


#42

Finally getting around to do something with my Vizia RF + system and Smartthings Hub. I have a 2 but it is still in the box. Running on the 1. So, before I begin, after looking at recent posts, thinking maybe another hub brand would be better. Any feedback on others for working with the Vizia system? Wink, like Smartthings is set up for many protocols so I presume has similar problems. Any recommendtions?


(Matthew Newman) #43

I have saved the Z-Wave Tweaker code to my MyDeviceHandlers in IDE and published it (for me). But when I go to My Smartthings App, Marketplace, SmartApps, My Apps, it’s not there. How do I get Z-Wave Tweaker to show up in my Smartthings App?


#44

You should ask any questions about using the tweaker in the author thread for that code. That will get you the fastest and most accurate answer.

But the short answer is that it’s not a smartapp: it’s a device type handler. So to use it, you select the device in your “things” list that you assigned to it and then you will be able to set the parameters for that device. But again, ask any follow-up questions in the tweaker thread.


(Matthew Newman) #45

Thank you. I’m sorry for the protocol breach. I’m very new to this.