Iris radio thermostat ct101

So, have installed an iris radio thermostat CT101 from “the Smartest House” and although I can control it using the touchscreen and through Google home and minis, the unit does not seem to respond to smartthings routines like Goodnight, I’m Gone, I’m Home, etc.

My previous thermostat had no problems, except it wouldn’t accept generic commands through google home like “turn up the heat” or “set the temperature to 20 degrees” thus my move to the CT101.

Another odd thing is if the thermostat is set to auto (heat/cool) and you say “set the temperature to 20 degrees” it only affects the cooling set point, not the heat set point. However, if the thermostat is set to heat only, then it works correctly…

I’m using the default device handler “CT100 Thermostat” as installed by smartthings when added. Should I be using a custom handler instead?

Thanks for any thoughts.



A custom handler will give you access to advanced features of the thermostat like humidity, mode settings and other parameters.

How are you checking the set points? If you’re looking at the screen in auto mode it only shows one of the two setpoint based on the current temperature or last mode (e.g. if you last mode before auto was cool then it defaults to the showing the cool setpoint and shows “cool” mode next to auto).

Thanks Rboy, I actually used your handler to get my last thermostat to work as well as it did.

The default handler seems to have all these things too. In the smartthings app, the mode cycles through Off > Auto > Heat > Cool > off > Auto > heat, etc etc. The thermostat panel does indeed seem to cycle modes as Off > Heat > Off > Cool > Off > Auto > Off > Heat > etc - but that does not seem to fix my issues regardless how I arrive to auto.

Routines in my activity log even say that when I’m gone it set the temperature to 17 but it doesn’t. I can only affect the temperature through voice command, through the google home or by the smartthings app (if thermostat is set to heat) or directly by the thermostat panel.

Everything works great really, just no control through routines, which a biggie.

It’s possible that the command may be getting lost when running a Routine due to excessive commands being executed by the routine (if the mesh is weak). You can verify by looking at the logs if the commands is being sent by the routine to the thermostat. If not, then you know the isssue, if it’s being sent but the thermostat doesn’t change the settings then the commands are being lost.

Have you tried using one of the mode based thermostat apps like: