iOS 8 issues?


(Psychoticide) #1

Any bugs or issues we should know about in the ST app when updating to IOS 8 this week?


(Chacho Morales) #2

i have run ios8 beta from the beginning and smarthtings is running good, in my case no problem.


(Psychoticide) #3

Very good to hear. Thanks for the update.


(Adam Fishman) #4

Running iPad and Iphone 5s on IOS 8. No issues yet


(Shannon) #5

Yes, there is an issue with iOS 8. Currently does not support background application refresh. Which means when you use your phone as a presence sensor to activate Scripts, you will have nothing unless you open the app. I already contacted support and they are supposedly getting ready to release an update


(Psychoticide) #6

I am also experiencing the same issue. The app is not even listed in the background app refresh settings. Hopefully they get the update out pretty quickly.


(Shannon) #7

I emailed them again this morning, and they are supposed to get back to me with an eta. We use our phones for multiple presence based scripts arriving and leaving, so it’s a big deal.


#8

I’m also having the same issue.


(Mike Northrup) #9

Checked my iPhone and iPad and SmartThings is not listed in Background App Refresh. Thanks for letting us know about this.


(Chuckles) #10

Has anybody successfully used the Support Chat feature under iOS 8 yet?

I’ve just tried it now to discuss why the IDE seems to be unavailable but it’s not working. So, it could be whatever is stopping the IDE working just now, or it could be iOS 8…


(Ron S) #11

Same here. No background refresh. Hope ST team gives us the upgrade soon.


(sandesh) #12

When using the smartthings app , there is a popup which says Smartthings wants to use your location in the background which shows up under Location services , if you enable this then it tracks presence properly even though it is not listed in the Background App Refresh. I guess that is the most important part which we need and after checking that option it detects and initiates actions even if my Smartthings app is not active.


(Psychoticide) #13

After re-installing the app, I was prompted again for the background refresh, but it took re-installing the app to get it to work. It appears to be working now…more testing to come. Thanks.

That said, it still doesn’t show up in the background app refresh.


(Keith M.) #14

I have an issue since ios8 and subsequent ios8 8.0.2. The app is very slow to respond, sometimes not at all using the SmartApp Garage door control for the LMF-20 switch. If you hit the icon, you get no response… sometimes delayed response, sometimes is works correctly.

I have reinstalled the Smartthings App as well as deleted all of the SmartApps and reinstalled to no avail.

I have opened a support ticket this morning. Hopefully I can get this resolved, as it is the whole install is not reliable enough for me to use.