Integration of Boundary alarm sensors

Hi community,

I have a Boundary home alarm system ( and the company has recently gone into liquidation, which means I’m a proud owner of a bricked hub and sensors without their Cloud platform…

The hub uses Z-Wave 700 to communicate to the sensors (motion, contact) and siren. In retrospect, apart from the dedicated app, the platform doesn’t offer much more than could be achieved with my SmartThings hub and a set of Z-Wave sensors.

I thought I’d see if the sensors as Z-Wave devices would pair to my SmartThings hub, so I set the hub in general device exclude, and tried to pair one sensor with the QR code… and it paired as a “Z Wave sensor”. Strangely this is a DTH rather than driver, but anyway… In the IDE I’ve tried changing the DTH to various different motion sensors, and I get the battery status but nothing seems to work correctly in bringing through it’s capabilities (motion, tamper detected, temperature, battery status).

I’ve never written a DTH (I’ve tweaked a few in the past) or Driver before so am interested in experts thoughts on this. I’d assumed that a motion sensor should be pretty standard, and there would be an existing driver out there that would work.

The fingerprint in the IDE is: zw:Ss2a type:0701 mfr:0000 prod:0000 model:0000 ver:1.08 zwv:7.14 lib:03 cc:5E,55,9F,6C. Do the type or command capabilities give anything away here?

  1. First to get this out if the way: DTHs, all DTHs, are in the process of being shut down, so there’s no point in spending time on those. You can’t add a new one to your account now, anyway. So whatever you come up with, it will be an Edge Driver as that’s how zwave communication will work in the new architecture. All the details about Edge Drivers are in the following FAQ:

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

  1. Yes, a straightforward motion sensor should work fine with SmartThings once you get the correct fingerprint, but it looks like your pairing failed because it has zeroes in the manufacturer and model number. (Those two fields are the fingerprint, btw. So all zeroes means no fingerprint to match on.) I’m guessing the issue was a security problem related to it potentially being a series 700 device, but maybe not.)

  2. anyway, first let’s see if we can identify the device another way, it appears that Boundary didn’t make its own hardware, so it may be relabeled. Can you show us a picture of any labels on the back or inside the battery compartment? There aren’t that many series 700 devices on the market yet (the smartthings/Aeotec hub, for example, is series 500), so I’d guess Popp, but let’s see if we can tell more.

  3. we need to know the model number of your ST/Aeotec hub.

  4. there is a possibility that your sensors in their existing locations will be out of range (series 700 devices have significantly better range than series 500, so the hub may not be able to reach them), but first let’s answer the previous questions, then we’ll look into that issue. Although if there does happen to be a sensor pretty close to the hub, say within 15 meters, try pairing that one and see if you get better results.

Well, that’s enough to start with. I do think that if they are indeed standard zwave sensors you should be able to get them working, although they may need some additional repeaters, so I am optimistic for the longterm. But one step at a time.

1 Like

After a bit of research, I am feeling a little less optimistic. :disappointed_relieved:

It appears like they may have encoded the sensors with proprietary firmware so that they can only be used with their own hubs, which they did in order to get their security certifications, That’s unusual but technically doable. This is what staff wrote back in 2021 in response to a question at Amazon UK:



Can these sensors, noting that they are z-wave, be paired with samsung smartthings, independent of the boundary/smartthings integration?


Hi Phil,

That’s a great question! Unfortunately though the answer is no as they are encrypted to the hub for security reasons. You can interact with any other Smartthings devices in your him through and the sensors will react to a number of different scenarios so it’s very flexible.

Many thanks,

Phil Wiliams
Head of Customer Experience see less

Boundary Alarm

Seller · 06 September 2021

So it’s up to you if you want to continue the research steps I suggested in my first post or wait and see if the Boundary customer community comes up with any additional information. :thinking:

1 Like

As far as the command classes listed, they just identify it as using S2 security at the highest level, so again, it looks like a failed pairing since you didn’t get anything else. :thinking:

1 Like

Thanks @JDRoberts for your considered reply, and the googling you did to find that on Amazon!

Yup aware of the DTH to Edge migration that’s happening which was why I was surprised it paired with a DTH.

I’d heard they’d put in some constraints around Z Wave devices, eg not being able to use your own Extender, but wasn’t sure if that applied to their sensors on other platforms. I was naively optimistic after it had paired and sent some messages to my V2 hub that it was just a driver problem to interpret the messages. It sounds like from what you’re saying that it’s not really paired properly, and the messages the sensor sends are going to be encrypted so not interpretable by the SmartThings hub :frowning:

As for the sensor itself, there are no markings on it as they’ve made their own cases so would need to try to open it up to see what’s inside… as you say, I very much doubt they’ve built their own sensors from scratch.

1 Like

…it’s doing something though. The sensor sent a temperature reading an hour ago which sounds about right. I’d have thought if it really was encrypted you’d not get anything comprehensible coming from the sensor without the encryption key to decrypt it.

Maybe I should try to bust open one of the sensors to see what’s inside… I don’t have anything to lose!

The sensor is close to the SmartThings v2 hub so I don’t think range is an issue… and have plenty of other powered Z wave devices around the house it could route through if needed.

1 Like

Hmmm… it does appear to be custom hardware, even if they have used someone else’s chip. Doesn’t sound promising!

They might only be using proprietary code for the security functions, that is, motion active/inactive or sensor open/close. Not auxiliary functions like temp. :thinking:. But until you get the correct driver there’s no telling.

You could try using Mariano’s “zwave thing” custom edge driver. If you can get it to pair with that we could get more information. But I’m not sure if it can handle devices that require S2 level security.


Yeah…I couldn’t find a conformance statement under their company name which is why I thought it might be rebranded since that’s the usual explanation for that.

But it’s also possible that they didn’t bother to get it certified for zwave since they were going to encode it anyway. Do you remember if it had the Z wave logo on the box or the user manual? Or just said “zwave.” They can’t use the logo unless they’ve been through the certification process, but they can say zwave if it’s a Z wave chip.

It has the Z Wave plus logo on the bottom of the sensor… and I’ve seen on the Liquidators statements they still owe money to Z Wave Europe, so they must be above board!

1 Like

It would still be above board without the logo, it’s just that it might not have gone through the full certification process, which means they wouldn’t of had to publish all their details. Graded security systems do sometimes prefer to keep some details obscure.


When it is paired with 0000 in the fingerprints, it has usually been to match away from the Hub.
Try to match it from scratch very close to Hub to see that Fingerprints has

1 Like

Does it give an exact name for the company? I’d still like to see a zwave conformance statement…

1 Like

thanks, will give this a go… I’ve added your Z Wave thing driver also to see if it pairs with that, but currently not wanting to pair at all after I’ve removed the device… will keep trying!


Ok, it does look like their own design (not rebranded). Not sure why the sensors are not showing up on the official zwave alliance site. :thinking:

Try a general exclude again if you haven’t already. Failed pairings can leave partial information in the network fields.

More success this time on pairing…

zw:Ss2a type:0701 mfr:044A prod:0004 model:0003 ver:1.08 zwv:7.14 lib:03 cc:5E,55,9F,6C sec:86,85,8E,59,72,5A,87,73,80,70,31,71,84,7A

Do those mfr, prod and model numbers help?

Oooh, I think we might be having more luck this time… it’s paired as a Z-Wave motion sensor (still a DTH) with motion, tamper and battery capabilities in the app. Tamper and Battery arent providing any readings yet, but it looks like it’s reporting motion accurately now!

1 Like

So, ideally now I’d be able to identify an Edge driver that matches the fingerprint and then re-pair this and then can do the same for the contact sensors next.

1 Like