Instructions Connecting Philips Hue Lux without Hue bridge?

Hello Smartthings users,
I am trying to connect my Philips Hue Lux bulb to ST hub without using the Hue Bridge. I have searched the ST forms, google and youtube for instructions on how to do this. From what I have read, people are able to do this but it is not suggested to do this because it will be paired to the ST bridge unless I do a next to impossible reset on the bulb. I really could care less if I lose functionality in the bulb or if I’m unable to reset the bulb. I bought it for $19 on Amazon. I just want it to work with my smartthings app on my iphone.

So… is there a link to a step by step instruction on how to set this up, or can someone graciously help the rest of the community out with instructions? People are saying this is possible, but I’m stuck at the moment.

Here is what I have done so far…
-In the Smartthings mobile app, I went to the second icon at the bottom of the screen that looks like 4 squares >> Things >> top right navigation >> Connect New Device >> Connect Now. On the phone I never see the bulb paired until I go to on my web browser. The display name shows up there as ‘Thing’. I know this is my bulb because I paired two separate bulbs.

One side notes to this: *** I have paired and uninstalled this bulb a few times off my bridge because I didn’t know if it was the correct bulb. After you uninstall it, you need to unplug the lamp from the wall for roughly 10 seconds. Then try pair again.

-In the browser I click the test name to make edits to the bulb. !!!AND HERE IS WHERE I’M HAVING MY ISSUE SETTING IT UP.!!! Here are my setting I am setting it as.

I press update and I restart the app on my iphone, I see the device on my iphone. As seen below, it looks like it will work, but the dimmer nor the toggle on/off work.

*** For iOS users. After you discover the ‘thing’ and make edits, double click the phones home button so you can swipe the app up to close it completely. I had to do this to discover the bulb in my things list on my phone after I edited it in the browser.

I thought Smartthings support could help me and they were pretty responsive in contacting me the next day. Here is how they responded.

Thanks for reaching out! It looks like you have a V2 Hub and your firmware is already all the way up to date! Unfortunately, we don’t actually support pairing Hue bulbs directly to the Hub. That doesn’t mean you can’t do it, but our official stance is to recommend the Phillips Hue Bridge. The community will continue to be a great resource for pairing your bulbs to your Hub! Sorry I couldn’t be more helpful. Please let me know if you have any more questions!

So if anyone from the community could provide help, it would be much appreciated. If I was not clear or if I need to expand upon to help find a solution, please let me know. Thank you kindly in advance!

I believe that device type is for a Hue lux attached to the Hue bridge. You have to get one of the others.

Did you try just using a generic zigbee dimmer switch? A smart bulb is actually a switch by device class. :sunglasses:

@JohnR might have one. Or @Sticks18 might know if one of the other direct connect Zigbee bulb types might work.

1 Like

I had the same problem.

Delete the device from ST

Add the ZigBee Hue Lux device type from the bottom of this thread:

Then power off and on the bulb and search for it and it will be discovered properly.


OMG… That worked! I used @JasonBSteele script that was in your link and followed your directions and it worked. The one part I got confused on, was where to add the script. If you go to and login, click the “My Device Types” link >> Then add new “+ New Device”. Add your script here.

If you have normal Hue Bulbs (not Lux) then there is also an "Improved Hue Zigbee’ device type that @Sticks18 made.

It allows you to pick the color temperature. It also adjusts the button color to be the same color as the light. And also fixes some refresh issues I think:

In addition, I’ve tweaked @Sticks18’s device slightly to add four buttons for the preset scenes that come with the real Hue app: Reading, Relax, Concentrate, Energize.

My ST coding skills are elementary… so any feedback welcome:


I’m trying to connect Hue White Bulb (not color) without bridge and I’m having trouble ST recognizing it. I don’t suppose I can reuse device type referenced in this thread. Any suggestions?

I’m using the device type in post 3 for Hue Lux and Hue White.

After turning on the bulb for the first time, ST should see it. You didn’t pair it with the Hue Hub previously did you?

Does ST say “searching” or “identifying” when you tap “connect new device”?

1 Like

I’ve tried almost every type but yes the one mentioned by Peter works also for new Hue White!
Thanks Peter!

I’m using the latest Philips Hue white and color bulb with hub v1 (000.013.00013).

I was able to add the light and tried the default device type as well as the two above scripts.

I can see events in the logs and am not seeing any errors, but the light is not responding to commands.

Has anyone else ran into this?

I don’t know if it’s related to your issue but I was just having some issues with my system. I was trying to pair a new device and the hub would never enter pairing mode (the lights on the front weren’t flashing). I was also having other odd behavior like manual actions from the app not working, etc. I rebooted my hub and while things didn’t work right away they did begin to come back after a few mins. I’m not sure if the reboot did anything or if I just got lucky with the timing of other issues but it corresponds to the time of your post (about 45 mins ago) so it might be worth a shot. After the reboot a bunch of the stuff I had been trying to do in the app fired all at once.

EDIT: After a bit more digging I think this was a hub lockup that was being caused by certain custom device handlers.

I was using the v2 hub for my case, sorry.

I had this same thing happen. I fixed my unresponsive lights one time by searching for new devices in the ST app, which reestablished my devices connection to the hub… It fixed itself. I have not tried it a second time yet because they have not went unresponsive since then.

Please help. I am not able to detect my hue directly. I was able to detect 3 of my hue lux bulbs after adding device managers from above. But the Hue Bulb does not show up. (No hue bridge) is there a device that I can tell it to look for in order to find it? If I can find it then I can go to the ide and link it to the correct device manager. I was able to add a fake device for testing the controls but it is not connected to any real devices. (If I knew the zigbee Id I could connect)

I went ahead and bought the hue hub for my color bulb. Still not able to control color through smart things.

I just deleted my bulbs and after trying to add them again I can’t get them to show up in Add Things. This is with V1 hub. Anyone else run into this issue?

Just to update, I was able to factory reset the bulbs with this remote:

(Hold 2nd and last button for 10 seconds very close to bulb)

Then I was able to re-add directly to smart things using this device handler:

Hope this helps someone else!

You can use the GE Link DH that’s already in ST as well. That’s what I use.

My Hue Lux is refusing to be discovered. Its new straight from Amazon with no bridge paired previously.
I’ve added the device handler and published it: Zigbee Hue Lux Bulb

Whenever I try to add a thing through the app it just times out searching for it. (Yes I have it switched on).

Any advice would be much appreciated.