Inovelli with SmartThings version 2


(Antonio Chagoury) #1

Hello,

I just bought a 4 pack kit of the inovelli plug and range extender. I bought them because they advertized as SmartThings ready. When I tried to connect them I don’t the inovelly plug listed. Am I missing something?

BTW I am using Version 2 of the Hub.

Thanks very much for your help!

@Eric_Inovelli


(jkp) #2

Perhaps this will help…
https://inovelli.com/smartthings-device-handlers/


(INOVELLI.COM FOUNDER) #3

Good evening @antoniochagoury,

Thanks so much for the support and for tagging me, I’m happy to help! I’m also sorry for the frustration, but I promise we’ll figure it out as they are definitely SmartThings ready.

So, prior to going into troubleshooting, let make sure you’re using the SmartThings Classic App.

The new app is not fully functional at this time and there’s been mixed messages from ST as to when it should be used.

Can you confirm you’re on the Classic App?

If so, full setup instructions can be found here: www.inovelli.com/nzw36-setup/SmartThings

Keep me posted, we’ll figure this out!

Eric
Founder | Inovelli


(Antonio Chagoury) #4

Hi @Eric_Inovelli,

Thanks very much for your note, I am glad you are here to help. So, let me give you some history:

  1. I bought v1 a couple of years ago and had been using until earlier this year. All of a sudden, a lot of my automations stopped working.
  2. After dealing with support for 3 weeks or so, they sent me version 2 of the Hub.
  3. I had to reset all my devices (PITA) and did so on the new SmartThings app.

After your note, I downloaded the classic app again. The problem now is that It is still loading my version1 hub settings and not the new hub’s. Is there a way to get the new hub loaded on the the classic app instead? I tried many way but wasn’t able to get it to switch.

If I can get some pointers here, then I can proceed to looking at the setup instructions you sent.

Again, thanks very much!


#5

If you downloaded/installed/configured all of your devices with the NEW (SmartThings - Samsung Connect) app, then you would have had to have created a Samsung account to do so (ST accounts don’t work with NEW app). I say his because if you originally had a v1 Hub, then you would definitely have had a SmartThings account with that hub.

Login to https://account.smartthings.com with your Samsung account/pw (email address) and then validate that the information is that of the v2 hub. Goto Location in the IDE and verify that you only have a single Location in there. If so, goto Hubs and validate you see a single Hub. If you have multiples of either while logged in with the Samsung account, stop and let us know.

I have a feeling that you may be logging into the SmartThings Classic app with your old SmartThings account and not the Samsung account.

FYI: What you see in the ST Classic app and the NEW app are reflective of the information being stored in the same IDE. Once you validate the information above, we can further troubleshoot if you are still unable to proceed.


(Antonio Chagoury) #6

WOW - this is so aggravating.

So, both my samsung and smartthings account has the same username (email) and password.
When I logged into the classic app it defaulted to the ST account. Okay, so I said, maybe I will “trick it” and change the samsung password to something else. But, when I logged in with the new password it would not let me through… i.e. the Classic App (On iPhone) does not look at Samsung for accounts, it just goes to ST. So far I have not found a way to choose against which service to log in.

Now, on the web app (api.graph.blah blah) then, yes, they give me a choice to select where to login (samsung or ST). Soooooooo… I stuck in la-la-land right now.

Any thoughts? … and yeah, this is absurd.

BTW, I did read a Samsung FAQ somewhere that they are working on an account migration process, but it still isn’t ready.

Any help, much appreciated.


#7

You should have that equivalent type of option when logging into the ST Classic app.

Logout of the IDE, logout of the ST Classic app, and then go clear the cache and force close the ST app and then go try opening it again and see if you are prompted differently.

As for the migration. Yes that’s coming. They are rolling it out in small batches. The way that’s going to work is that you will see a banner page show up in the ST Classic app and then you will follow the instructions. Basically you will be transferring everything in the ST account over to your existing Samsung account, consolidating everything into one account.


(Antonio Chagoury) #8

Thanks guys. I was able to login (I had to click the “New to SmartThings” link and only then it would give me the option to chose.)

I also was able to connect the outlets, so good to go there!.

Now, if only I could figure out to connect my garage door relay… last one! I tried z-wave exclusion and resetting to no avail. I cannot get ST Classic to see the relay. I have a Evolve LFM-20 that worked before.

I tried adding the device manually through the online interface, but I am getting a server error on save. Sigh.

Again, thanks guys!


(jkp) #9

Try logging in to IDE using an incognito/private tab in your browser.


(Antonio Chagoury) #10

Same error:

Error
500: Internal Server Error
URI
/device/save
Reference Id
426a8e6a-776d-4298-acbb-67415cd755a7
Date
Sun Apr 15 13:04:19 UTC 2018