IKEA Trådfri

How did you get on? Any joy getting these set-up? Do they work fine?


I just grabbed a bulb + puck set and the remote from IKEA today. I managed to pair the bulb with ST and it works pretty great but haven’t managed to get the config right that allows me to have both the bulb paired with ST AND keep the remote working. I noted further up the thread that someone did manage to get that going, but that didn’t seem to work for me.

I also managed to pair both the puck and the remote with ST, but like others, I haven’t managed to find a config for the handlers that works. I’ll keep fiddling with them and see if I can get it to go. Honestly, though, I’d be OK if I could pair the remote to the bulb while the bulb is also connected to ST.

I’ve unpaired the bulb from ST for now to preserve the remote control ability. Would like to reintegrate them both at some point.

Pretty excited about this move with IKEA, though. The pricing and the lack of an additional bridge/hub are definitely good selling features.

1 Like

I was also able to get the puck AND ST to control the bulb, took a few times to get it to work, my steps, flashed bulb 5-6 time to unpair (had already paired to ST) push puck button 6 times to unpair it, add device to ST, 2 things showed up (puck and bulb), while add things was still in the discovery mode, put puck next to bulb and held pair button for about 15 second until the bulb dimmed and brightened, then back to ST and confirmed the added devices and changed the handler on the bulb and left the puck as just a thing, puck works and ST work…

1 Like


I think that’s what I tried, but it sounds like it’s worth persisting with it a few more times.

I feel like a nutter resetting the bulb so many times. :slight_smile:

1 Like

Has anybody had any luck getting the motion sensor to work? I was able to get it connected but haven’t found a device handler that works.

It took me several tries to get it to work. The first few times, only the bulb would show up… when it finally worked, both the bulb and the dimmer puck showed up in the Add Thing screen (bulb=Thing, puck=Unknown).

I’ve got a few GU10 with an additional 5 button remote recently. However, all GU10 managed to pair up but not the 5 button remote. Could anyone give me some advises? I’ve tried quite a few times to reset it by quickly pressing the pair button for 4/5 times then long press it for more than 10 secs. No luck getting it show up when searching devices.

I’m going to head to Ikea and pick up some GU10’s and a puck for two spotlights i currently have over the Wife’s dressing table in the bedroom. I’m hoping the puck will give the her the ‘dumb’ switch she likes and the ST integration will give the ‘smarts’ I like. It seems like it’s possible to have both the puck and ST controlling bulbs, with a little trial and error.

Quick question though, my ST hub is in my hallway, where I have no GU10’s. What is the best way to pair with no GU10 sockets near the hub, will I need to fashion some sort of DIY GU10 lamp and plug it in next the hub?

Should have researched before posting, looks like you buy a GU10 to E27 adapter on Amazon :+1:


There’s no Device Handler that’s been written for the Remote yet - I’m in the same boat as you.

I managed to get the device to the SmartThings hub by pressing the pair button 4 times, then holding the device very very close to the hub. [Edit: I might have also held the pair button in] Once I did that, it saw it as a “Thing”. I could then dial in to the GUI of API and change the device type between different devices; however - it doesn’t matter what device type I’m using at the moment, it can’t do more than receive the battery status.

Going forward, someone will write a device handler that will work (currently, no-one can even see messages coming back when you press the buttons!), but that’s being worked on over here: IKEA Tradfri Button -- help needed

I’m hoping to start taking a look myself, but I’m completely new at Zigbee, so I’m expecting a steep learning curve!

I totally get the idea of no DTH available atm. But the problem I have is I cannot even get the ‘thing’ show up in the app and hence can’t really get much from it even if I wanted to play with ZigBee. I’ll try to pair it again later this week and see if I can get any luck from it.

1 Like

I’d give it a try where it is, I did mine from a fixture across the room and it paired fine, may need to run with the puck to the hub holding the connect button if it doesn’t show up initially though…

Apologies for the newbie question ; just got the ST and a set of Ikea E14’s to try. Exciting :slight_smile:

All works a treat with the new handler but linking them to the Amazon Echo is a different story. Grouped 3 lights fine and it will dim/brighten on request however the colour resets to warmest when the light level changes. Still working out how this can be fixed so any pointers really gratefully received. Does not do it if I use the ST app. I have updated to the latest handler code also

Which device type handler are you using?

Your wonderful code :slight_smile: Checked it was the latest version as I saw you made a change to cover something similar. Might be me being daft … usually the case!

There was a bug in the code that prevented disabling level and color temperature linking, if you still experience any issues with the latest code then post in this thread and i’ll look into it.


1 Like

This would seem a promising place to start for creating a Usable DTH for the remote. Maybe?


Still seems to do it - even reapplied the latest code in case. Also altering the colour temp in the app. I have double checked the link option is set to off. Probably my fault somewhere :slight_smile:

Are you sure that you are setting it to off and pressing “Done” in order to save the changes? i just checked and it works for as it should for me and i have no changes locally that’s not published

Just picked up an IKEA Tradfri bulb and I am having trouble pairing it directly to the smartthings hub. I do not have a puck any advice. I have already done powercycling 6 times and the bulb flashes once but never shows up in the add a thing screen. The bulb is literally sitting on the hub.