Ikea Tradfri Remote Control

I have E1524. It was initially working great. Now the plugin is broken and my previously setup automations in the new app no longer work even though the app shows the appropriate button being pressed. So both the app and cloud are broken for buttons. :frowning:

Yes, please try to pair it. Do the reset on the button as pairing. The DH should be then Ikea Button. If it is still not working, please post here what you can see in the Live Logging meanwhile pairing.

Do I remember correctly, you were the guy who told, “I am using the new app”…? :laughing:

So, it is working, but the new app is broken as usual. You should use Smart Lighting or WebCore. :wink:

Can you see anything like this:

11:13:42 PM: warn Binding Table Header:
[transactionSeqNo:65, status:0, numTableEntries:3, startIndex:0, numEntriesReturned:3]
Table Entries:

And

11:13:42 PM: info Parsing binding table - 'catchall: 0000 8033 00 00 0000 00 6660 00 00 0000 00 00

Or do you have a Warning over there? Anyhow, you might get better if you replace your battery first.

Have you tried to pair the remote to a Tradfri bulb to test is it working?

Anyone know how to have the up/down buttons on the IKEA remote to raise/lower the brightness by a percentage instead of setting it to x level?

@danielccm, It depends what you want to control?

Option one, I am using the button with a Tradfri bulb too, paired the button close to the bulb by holding for 10 seconds and it controls the bulb directly too. It works for changing the brightness as IKEA designed it.

Option two, use the ABC Advanced Button Controller Smart App from here:

It has option to change the brightness by a stepped percentage, but I don’t see any way to have the continuous changing of brightness for long press inside Smartthings’ environment, but it works with option one.

By re-reading your question, I think your right choice here is ABC.

Could you check, that the DH in use is the Ikea Remote? And sure not the custom DTH.

You can see, that there are some teething issues with the remote. I am still investigating it. It looks like some behaves differently.

I can see only one issue with mine, that there is no held for the middle button. Only this in the log. And a left button press (meanwhile holding down the middle button). I’ve read some other people haven’t managed to make the middle button held working neither.

11:55:24 PM: debug Parsing message from device: ‘catchall: 0104 0000 01 FF 0000 01 6660 00 00 0000 00 00 0100’
11:55:24 PM: debug Creating event: [name:button, value:pushed, data:[buttonNumber:4], descriptionText:Living Room remote left button was pushed, isStateChange:true]
11:55:24 PM: debug Parsing message from device: ‘catchall: 0104 0005 01 FF 0000 01 6660 01 01 117C 07 00 02000000’
11:55:23 PM: debug Parsing message from device: ‘catchall: 0104 0008 01 FF 0000 01 6660 01 00 0000 04 00 FE0000’
11:55:23 PM: debug Parsing message from device: ‘catchall: 0104 0005 01 FF 0000 01 6660 01 01 117C 09 00 8A00’
11:55:20 PM: debug Creating event: [name:button, value:pushed, data:[buttonNumber:5], descriptionText:Living Room remote middle button was pushed, isStateChange:true]
11:55:20 PM: debug Parsing message from device: ‘catchall: 0104 0006 01 FF 0000 01 6660 01 00 0000 02 00’

But I guess, it is normal. It first registers a single push. And it doesn’t wait for the held state.

I’ve duplicated the important button automations with Smart Lighting…in the new app :slight_smile: at least until they fix the cloud issue breaking custom automation rules for buttons.

I am not even seeing any of the button push actions. Just the battery status in the beginning when it is being paired and then it goes silent. Should maybe try returning the device?

Have you got any Tradfri bulbs? Pair it to any of those. Then you can test it first. But I wrote this already.

Im glad im not the only one… This has been driving me nuts. I have 3 of the 5 button remotes for various room lights and they were working perfectly, then all of a sudden about a couple days ago they just stopped working. Looked a little bit last night in my app and saw that i can see the button presses just fine, but now there are no options for editing the pressed/held for each button. Wasnt sure if something was updated with Samsung on the backend thats caused this or if there is a bug in an update. Is this the same thing that you are seeing?

I have both old and new versions. Both stopped working now. and initially I had some issues with setting actions but pairing was fine. No problems with pairing. The issue I have now is that the app dumped all the button actions so they do nothing now, and you cannot edit them in the app. This other topic describes the same issues Im having now. Buttons stopped working after latest iOS update

Yeah, I see all the issues what people are saying about this buttons not working.

Have you tried to add the actions through Smart Lighting or webcore?

I guess all the issues what are reported are from the new app. I am not using the features over there because when I paired my remotes the app was crashing when you tried to assign any action. :smiley:

I think, I dodged this bullet now.

@Brad_ST, is anyone looking at this issue with buttons and the new app not working together?

Not sure I understand what you mean by adding the actions through smart lighting? And Im not sure how to get add anything via the webcore as I cant add any actions via the web interface at least that I can find. I just got a response from support essentially saying that since the button is not an officially supported thing, im SOL. Not really sure how that happened considering that they literally were fine until a couple days ago… Might have to look into writing my own handler as much as I dont want to…

custom device handlers only change the UI in classic. The DTH tiles only map to classic. The new app uses plugins that can’t be manipulated by the DTH other than assigned a whole new one.

Which scrad are you using? I don’t see any issues.

Yes.
I believe the issue has been identified.

Do these run local?

Nope

(10 char)