IFTTT and SmartThings (UK accounts)

Nice - hurry up :smile:

So, it looks like this might be working now, been able to authorise properly but yet to try a routine out! Other apps now have my hub showing correctly where they didn’t before and I no longer have to log in twice…

@mohawk_matt what mobile OS are you running? @Arron_Forde could you try SharpTools again and see if you can authorize now?

I just authorised it using a web browser through the IFTTT website, IFTTT now shows as a smartapp within SmartThings and I could select all the devices I wanted to allow it access to. I’m on iOS9. When you sign into the SmartThings site now (graph.api.smartthings) you no longer have to click on locations and sign in a second time it automatically logs you into the eu site

Trying to get SmartRules to work but I’m now stuck at the next hurdle, it says “Client is not associated with a SmartApp in location XXX” which is an improvement over having no locations but still doesn’t help much.

IFTTT still can’t access my devices!

1 Like

Just tested this! It WORKS!

1 Like

Have you actually got something working, any recipes I try can’t actually access the required devices :frowning: so close!

Never mind… Jumped the gun! Hit the same snag you did!

EDIT: I have also noticed that it is now actually authentication against the US server, which must have some kind of federated authentication over to the EU servers.

Getting there ST, I have to give you that!

Once you guys have authorized the SmartApp, what happens if you open up the SmartThings mobile app and attempt to edit the list of authorized devices for the SmartApp from there?

I still get the Problem accessing your xxx sensor message

This doesn’t look good. I’ve Just tested with:

LIFX - Fail, doesn’t even start the smartapp
SmartRules - Fail, comes up with error "client is not associated with a SmartApp in location"
Amazon Echo - Fail, comes up with error "client is not associated with a SmartApp in location"
IFTTT - Fail, connects but cannot access sensors / actuators / devices

Lets all be honest though, we have all jumped on the band waggon of “It’s working!” Even before anything has been announced :slight_smile: -

Either that or we’ve just beta tested the fix and found a law already.


When i now log into graph.api.smartthings.com it shows i have no devices or smartapps or even a hub… when i jump to locations im not asked to log in again (Progress!!) but it does then switch me to graph-eu01-euwest1… and then all of my ‘stuff’ comes back… It feels close now!

on nexus 6
SharpTools - Fail, comes up with error “client is not associated with a SmartApp in location”

but i can select location now, so there is progress :smile:

I got excited… Then I got unexcited… But I’m happier than II was at lunch time.

1 Like

It would be best if we waited for an official announcement.

At the moment, various Community SmartApp authorization procedures are not functioning, even for typical US based installations.


I hope that this is due to getting UK OAuth in sync, but no way to know, and, frankly, I’m not impressed that the above error is occurring without any warning to us Developers as usual.

1 Like

Oh I got so excited then I shot straight over to smarttiles.click and found that there is other problems :frowning: went to connect IFTTT but then noticed others having problems there so holding off for now.

Back to patiently waiting :wink:


Now i get the following as @Lind_Lau_el_Loren mentioned:
“client is not associated with a SmartApp in location xxxxxx”

1 Like

Yup, exactly what I did.

“Life over the pond”

This is somewhat jumping the gun as there is no official announcement or expectation that it should be working yet.

I have a feeling we might be entering this second stage…

… or hopefully there are some different aspects about this working from the UK that the documentation will address.


+1 for selecting a good gif