IDE is extremely slow

just hitting save can take over a minute
in the simulator, going from set location to the first settings page can take 3 minutes.
i am using chrome on mac with a very fast internet connection.

is this normal?

Not typically. Keep an eye on this thread for updates: SmartApp Caching update

Using the IDE has actually become worse and worse for me over the last few months. It’s now to the point that it’s pretty much unusable, as my browser completely freezes for minutes at a time every 5-10 minutes (or every minute if I have a live logging page open) . This occurs whether I use Safari or Chrome or Firefox. And it ONLY occurs when I have ST’s IDE open.

Hang tight. If you are experiencing slowness right at this instant, it may be due to the platform release: CoRE SmartApp Changes - 1/5/17

Thanks for responding, Aaron.

FYI - The slowness with the IDE has been persistent for months (at least for me), so I don’t think it’s due to the recent update.

I also have constant issues with it being unbearably slow. Making any modifications to my smart apps or device handlers takes forever because it takes a good minute or so to even load the list of smartapps/DH. I also seem to have multiple instances of my username or something because I have to be on a specific server or it shows me as having nothing, no hub, devices, or anything. It’s very strange.

For those experiencing extreme slowness, do you have the GitHub integration enabled? That may be the reason for the performance issues, especially if it’s pretty consistent (e.g., not just during a platform deploy).

I have the GitHub integration enabled. Is there any way to avoid this slowness without disabling it? And is it normal for me not to be able to use any IDE server except for a specific one? If I try and use, it will come back saying I don’t have any hubs at that location and I have to go to My Locations, click on the name of my home, and then it switches to and I can then work with my SmartThings.

I have Github integrated.

Are you suggesting that I disable it?

Yes, that’s normal. You need to drill into your specific Location to make sure you are publishing custom code to the shard specific to your Location. Details here.

Not necessarily; it’s a trade-off. The GitHub integration brings some conveniences and benefits, but we’ve also observed that it can negatively impact performance.

Okay. That’s what I’ve been doing. It just seemed peculiar was all. I bookmarked that specific log in for getting to the IDE. I’ll try disabling Github to see if it improves the situation. Thanks for the assistance.

1 Like