Icamera2 (Sercomm)

I found this on Github, it gives me live feed and you can snap a pic, I am still trying to work out the motion (I have a Mac)

1 Like

Is there a trick to getting this to work? I have 3 of these cameras Icamera2. I have them working on there older code generic but would love to see motions and snapshot work in SmartThings. I cant get the stream to start


Capt9859 Do these still work? I haven’t been able to get the !camera2 working with this code. I have them working on PS’s Generic Camera Code


I loaded the device handlers and smart apps but when I hit “+” to add my cameras manually, the devices aren’t there as an option.

I have the same problem :frowning:

was anyone able to get this to work. im thinking of going completely getting rid of xfinity home and putting these on smart things. wanted to know before i buy smart things cameras

Hi Capt9859, can you share more detail on how to add the icamera2 to smartthings please?
I installed all 3 smartapps and device handler from the link you provided, thanks for that,
and then I used wps to pair the icamera2 to my router and got ip address,
then I run the icamera manager(connect) to add new fixed ip camera by adding ip etc…
and then what? I don’t know what to do next and where can I see the camera view…
thanks in advance!

Does this code work for sercomm OC432? Also can you view live video away from home? Or does it only work while on home WiFi? Thanks

I have the stream working for this however I had to update rstp:// tags in the handler code to http://{state.cameraUser}:{state.cameraPassword}@{state.videoIP}:{state.videoPort}/img/video.mjpeg … keep in mind you need the camera interface unlocked and configured as well by typing in http://localIP/adm/enable_ui.cgi (you will see OK) Then type in http://localIP use administrator as login and leave password blank (make sure you preformed a factory rest prior to any of this) … setup everything in there as required. I am still having issues with using the screenshot, motion, and NV toggle settings if anyone has some insight. Thanks!

1 Like

Do you think anyone can share a step by step direction? I know its a big ask!

So far, I have copied the device handler, all 3 smart apps and was able to add the device. Changed RSTP to HTTP on all 3 lines in the code. Specified my video ip and port (I have used default 1024 as per the manual). In the classic app, Smartthings cannot connect to the camera. Don’t know what I am missing

I have reached the same dead ends. I’m frustrated. I’ve tried PSTUARTS Generic Camera, This App and Device handler, I’ve set up Carters ICamera app and device handler. None of these can seem to pull a video stream down from my camera. I have 4 of these camera’s and Spectrum Intelligent Home is being discontinued as a service in a month from now. I would love to be able to use these.

1 Like

The #1 step should be to do a complete reset on the camera to delete any unwanted settings (passwords, etc) from your original vendor (Comcast etc). Have you done that?

You should start with a full reset to delete old settings that were entered by the camera supplier.

That was the first thing i did. I am able to command snap shots. But no live video.

Do you have access to the GUI?

Yes I had access to the GUI. I can locate the stream and stream live video via tinycam. I tried setting up all of the video stream types. I also ended up forking the code and modifying it slightly at one point. Nothing would make live video stream on my smartthings interface. Everytime I try to stream it flashes a video player black screen then directly back to smartthings dashboard.

If I recall well only the MJPEG stream worked (and is still working) for me in SmartThings. Can you see the MJPEG stream with your browser on your internal (home) network? The same link should work in SmartThings. At least with the basic pstuart code I’ve been using. Also, the issue could be related to authorization, make sure you have the correct user name and password.

Thanks for the assist. It does not work ive done all of these things.

I’ve struggled with it a bit myself. Do you see the stream in your browser? You can also check the camera device related variables in SmartThings Groovy IDE to see how the full streaming link looks like.

Have one working fine (takes 5 pictures when back door is opened or closed)
Video I have not been able to get to work. It was working with another vendor’s automated alarm system so I know it can work. Looks like the new smart things app won’t let me use the old code (unsupported camera)… so I will try to create a new working app