I need info on webCore update installation process

Excuse my complete ignorance but I am very new to webCore. I have successfully installed webCore using manual and Github methods. My pistons all worked correctly. I screwed up updating yesterday but a reinstall was quick and worked fine. My question is when I’m in the app and a message appears at the top saying there’s an update available, what’s the procedure to do that? I log into the ide and see the option to update from Github, but the only files I see are in the “Obsolete” column with nothing appearing in the in either the “Conflicted” or “New” columns. Excuse me if this is not the correct place to ask this. I have searched for the answer and searched the Wiki but I guess my search terms are inadequate. Either the answer or pointing me to a source for the answer would be greatly appreciated.

Easyest way is to put up WebCoRE site in github integration.
Go to smart apps in ide.
Chose update from repro.
Chose the (up to 4) that is available as new.
Chose publish and hit continiue.

The bits left on howto integrate github you find in these forums
Good luck :slight_smile:


Thank you. I’ll keep checking but my update from repository looks like this. Nothing in New column. If I log into Github directly from my browser, I can see the new code with today’s date as opposed to what’s installed on my SmartApp that shows yesterday’s date. I’ll keep plugging away. Thank you for the answer though! At least now I know the proper procedure.

1 Like

Thats the one you do update. You are 5 clicks away from the right path :slight_smile: 4 at the left. Publish and continiue.

Oh I get it. By clicking Obsolete files I’m directing what’s to be updated. Excellent! Thank you!


Thougt about editing :wink:

All is running swimmingly. Thanks y’all.


I like it! Another happy ending :slight_smile:



“Obsolete” means there is code in Github that is newer than what you are running. A clearer label would be “updates available”.

“Conflicted” means that an update is waiting in Github, but you have also made changes to the code yourself, which an update would overwrite.

“New” means you have never installed that code.

Thank you for the details.

Probably an ever dumber question, does anyone know how to update without the GitHub integration? Is it as simple as copy and pasting the code in again?

Yes, copy, paste, Save, wait, Publish, For Me, wait. Repeat for all four apps.

OK thanks, I figured but didn’t want to find out after I broke it that isn’t the case. haha

My dashboard tells me there is an update available. V0.2.0fa.20171011. I have V0.2.0e2.20170808. I used to be able to upgrade from repo, but now the field is blank. I can’t figure out what has changed. Any help would be greatly appreciated

I’m at the same point and can’t figure it out. Webcore shows update is needed but nothing shows up in update from repo.

It’s definitely a new update, one ahead of my current and I have no pc access for 9 more days but thanks for the reply

I also am struggling with this update. I click on “update from repo” I get another box saying “SmartThingsPublic (Master)” and I get a list on the right under new with approx 70 things in there. None are named Webcore, in fact I don’t recognise anything in there. I don’t think I did the GitHub thing proprly so forget all that and if possible point me to the way I got WebCore originaly, which was to copy and paste in GitHub.
It would be much easier if the “info” that tells me there is an update when I log in to WebCore, were to give a link to the update.
I am in UK so maybe GitHub integration is more complicated here, I find copy and paste very easy so will stick with that.

Hi Robin, thanks for that. I followed the instructions and it worked first attempt.
One other thing, I tried to do the same with my other Smart apps IE: MiHome connect, google home helper, Tp link connect and a couple of others changing the relevant name, author, etc but nothing else would work. Should it be the same update process for all SmartApps or is the WebCoRe one unique?

Thanks again anyway.

As for updating SmartApps and Device Handlers in IDE, the process is the same across the board with the exception that every SmartApp has its own Repository that you update from. In addition some of those SmartApps might have additional things that you have to update as well outside of IDE ((ie: Ask Alexa and EchoSistant).

If those didn’t work, verify that you correctly created the repository using the exact spelling of the Owner / Name / Branch. That information can be found in the developers doc or in their thread in most cases.

Also, if you are adding a repository to a SmartApp or Device Handler that you had previously created manually, you have to update each Device Handler and SmartApp manually after you create the Repository. For a SmartApp click Edit and select Source Code options and select the Repository and Update. For a Device Handler just edit and select the Repository and Update.
You will then be able to use the Update from Repo function for those.


I just added that Repository and did update from Repo