SmartThings Community

I have issue with Schlage lock!

Hi everybody,

I face issue in the distance between Schlage lock and ST hub as I will explain down.
My home has 3 floors and the devices are distributed as follows:
ٍSmartthings hub is in 2rd floor ( my apartment)
GoContrl Siren in 1st floor (stair room)
Schlage lock in Ground floor (Front Door of home)

the distance between them as following (evaluative):
ST hub == 7 m ==> GoControl == 5 m ==> Schlage lock
In this distribution, I lose the connection with Schlage lock.

Front View ( Hand Drawing) :grin:

As I know the GoControl Siren should be work as repeater!!! But I lose the connection with lock!!
I think the distance is not too far.

So, what is the reasone for that??? How I can solve it??

Temporary solution, I put ST in stair room (3rd floor) . But I lose some zigbee device in my apartment.

If there is solution, it will be fine. Becouse I want return ST hub to my apartment to be able to controll other zigbee device.

Thanks

You will need to have the ST hub really close to the Schlage lock during pairing. Like a few feet or less, that is the way Schlage does the security for set up. After that you can move the ST hub to your normal location. As long as you have a good enough z-wave mesh which includes powered repeaters between the hub and lock you should be okay. You may need to do a z-wave repair after everything is back in place. Or add more repeaters to get a good mesh.

Dear @cbsmith
Thank you for your help.

I’m paired in 3 or 4 meter Successfully. After that, I return the ST hub to my apartment without doing zwave repair. After some hours, I losed the connection. Then, I trying using zwave repair but not solve. Maybe it’s useful if there is connection between them. I don’t know.

I will try to return the hub , then I will do zwave repair if there connection with schlage lock.

But I think the distance between hub and schlage lock is 13m if it’s without GoControl siren :rotating_light:. This distance is not too far.

About using repeater, as I said I used GoControl Siren. But I don’t want if there is any setting is needed.

It would seem like whether it’s supposed to or not, the Gocontrol Siren is not repeating… It may also be having a signal issue reaching the lock.

Keep in mind that it’s not just about distance, there may be other factors such as interference (especially passing through floors) that impacts signal.

The locks work best when they can easily reach a device that supports the ZWave beaming feature (see this article: FAQ: Pairing Schlage Z-Wave Locks)

I use the GE Zwave plus switches for this, I have one in the light switch box next to my door.

Read the linked article and look for a good repeater device that supports beaming and ensure its installed CLOSE to the lock on the same floor.

It will only work as a repeater if it was paired with the hub while connected to the mains. You can confirm by this by looking at the “raw description” of the device in the IDE under My Devices. It should start with a zw:L or zw:Ls if it’s anything else like zw:S or zs:F etc than it’s not in repeater mode.

3 Likes

@rboy - this is a really useful bit of info!

1 Like

Thank you @nathancu
I solve this issue.
I returned my hub to my apartment, GoControl Siren move up from 1st floor to 2nd floor (Front of my apartment) and keep Schlage lock in ground floor. There is no obstacle between Siren an Schlage Lock because both of them are in stair room.

Dear @RBoy thank you very much for your useful information.

I got it zw:L…

So it should be working as a repeater.

I did z wave repair and there is no error show. :wink:

Thanks everybody

1 Like