I can connect only 1 Lifx bulb to Color Smart Apps


(Realsol) #1

I have 3 Lifx bulbs. Whenever I try to add all three let’s say to the ‘Smart App’s’ app, when the app is triggered, only 1 bulb changes color. If I want all bulbs to change color, I have to create 3 seperate apps. So this has forced me to use IFTTT which works but can be slow at times. This only happens when trying to change colors. The bulbs work fine when shutting on and off from ‘Hello’ routines.

Is there anyone out there that have experienced the same problem? I don’t want to remove everything and re-install if it is a ST/Lifx problem.

Thanks


(Realsol) #2

OK. I did more testing with my Lifx bulbs. I currently have tickets open with Lifx and ST and will update this as I find out more answers. Here is what I tested:

  1. I Created a basic ‘Smart Lights’ app including all 3 Lifx bulbs to have the colors change to blue when I click on a Momentary Virtual Switch. Only the first bulb listed in the app changed colors.
  2. I then deleted the 1st bulb from the app. When I clicked on the switch, the new 1st bulb listed in the app changed colors. Thus, only the first bulb in this app ever honored the color change.
  3. Then, I added back in my 3rd bulb, but changed it to only ‘Turn On’. All three turned on with the Virtual Switch.
  4. Then I changed it to a ‘Turn Off’. All turned off.
  5. Then I created the same 4 tests with a Virtual on/off switch. Same results as the Momentary switch.

I will mention that before I did the following tests, I removed all 3 bulbs and the Lift Connect app from ST, removed the bulbs from the Lifx app, rediscovered and claimed them in the Lifx app and reinstalled everything back in ST.

In conclusion, the Lifx Bulb integration in ST works fine if you only included 1 bulb in each SmartApp, or if you never plan on changing the bulbs colors. You will need to use IFTTT in order to do this as their integration, while slow at times, just works.

Waiting to hear back from both ST and Lift to see if there is some work around.


(Realsol) #3

Well, since no one has responded, I guess I am just Lifx and SmartThings new beta tester. Here is the response I got from Lifx:

Hi Robert,

There are some technical issues that ST is working on, on their side, to address issues like the one you are experiencing. Our HTTP API allows for calls of single bulbs, groups, and even scenes, for integrations that have built support for them.

I know they are actively working on resolving the issues, as far as I have been made aware, so I would keep an eye out for updates to ST software that could improve the connection in this case.

If there are any more questions that I can answer for you, please let me know.

Thanks,

Taber

So I guess only time will tell. I still have a 3 week Amazon return window.


(Realsol) #4

For those watching this thread, here is the response I received from SmartThings:

Hey Robert,

Thanks for reaching out and sorry for the delay. We are releasing a new version of the App soon, so hopefully that will help.

In the meantime, have you tried uninstalling and reinstalling the app and seeing if that helps?

Regards,

-Karl
SmartThings Support

Hopefully things will sort out soon as I really like the Lifx bulbs, although I have lost connection to one of the bulbs a couple of times and had to ‘Reclaim’ them in the Lifx app.


(Vagelis F ) #5

LIFX connect worked great for me for the 4 bulbs.THe thing is that one month ago 2 of my bulbs didn’t play so I removed them from any smart app and then re-installed them and played nice.One week ago only 2 of my bulbs work out of 4.The one was the same as before so I uninstalled all 4 bulbs,removed lifx connect, did 3-4 times rebooting of my European hub v1 ,but even if they are one and controllable by the LIFX official app without problem, Smartthings app sees all four of them but shows a questionmark.

I think LIFX connect UI changed also one week or more ago but now I cannot use them in my Aeon minimote or in any other smart app.
If anyone can help me fix them I will appreciate it.

Thanks


(Realsol) #6

@xneo1, I actually gave up trying. I can control them individually in ST, but I use IFTTT for all of my automation for multiple Lifx colors. For instance, I created a ‘Virtual’ switch (Momentary) in ST called ‘Neon’. I setup my minimote to trigger that switch when I press a button. When that switch is triggered, it then fires my IFTTT recipe turning on the colors I assigned them in the recipe. It also triggers a ST SmartApp that in turn turns my Hue lights to a set color. This sucks, but it works.

I also setup my Amazon Echo to recognise this Virtual Switch. So I just say “Alexa, turn on my Neon Lights” and walla… They all come on.


(Vagelis F ) #7

I have also setup a Domoticz bridge (with the ST app) on a Raspi B+ which recognizes Lifx, easubulb and others and all are switches on ST. When LIFX connect worked I had only my Easybulb switches on ST.Now am going to setup the LIFX also.maybe they work without any problem and without the LIFX connect!

I will report back, when I have news!

For LIFX I hope it’s a matter of time to work again!


(Brandon Sullivan) #8

I still cannot get the Smart Lighting to turn on (or do any changes) to more than 1 bulb at a time. I’ve done some stuff in Tasker to try and automate it all, but it’s a pain doing it that way, but at least that lets Google integration work.


(Rick Pittser) #9

I’m still experiencing this as well. I have to use IFTTT to change LIFX scenes, which works, kind of, most of the time. I would love to natively setup lighting scenes in ST which includes LIFX and other types of lights, and things, but this pretty much makes that impossible. So I have IFTTT for LIFX and use Rule Machine for other lights/things. Anyone hear any recent news on the LIFX front?


(Realsol) #10

I haven’t heard anything. I want to sell my Hue lights and hub and purchase 3 new Lifx bulbs but was really hoping to see SmartThings get this worked out. Are you running the Android or IOS app, not that I think it makes any difference?

Also, where do I find the Rule Machine app? My Smart lighting keeps failing in other areas of my home.


(Rick Pittser) #11

I have never had Hue lights, but I really like LIFX. If you want to schedule lighting with just LIFX lights, their app works really well. Luckily that is mostly what I have except a few hall lights that weren’t worth the expense. I have iOS, but I am sure that doesn’t make a difference. This seems to be a known issue.

Rule Machine is here:

I have basically gotten rid of all other automation, and just use RM for everything.


(Realsol) #12

I am guessing Rule Machine must be an IOS only app. Back to the Lifx support, Samsung really should stop advertising that they control these lights or at least be honest. “SmartThings supports ONE Lifx bulb at a time”. It has been more then a year now. I’m sorry, but in my opinion, things were much better before Samsung showed up.


(Rick Pittser) #13

Rule Machine works on any platform. Install from the IDE. I agree it is pretty sad that they can’t support LIFX after this much time.


(Realsol) #14

Yeah. You would think that if a small company like IFTTT can control LIFX bulbs - it is really a sad case that Samsung can’t. Are you listening Samsung, or SmartThings. Let’s get with it or remove it from your supported devices? Some folks like me don’t purchase things until SmartThings say they support it. Could it be a class actions … Get it together or sell SmartThings to Google.


(Realsol) #15

At least be honest about what you can and can’t do. I understand maybe a few bugs… but it has been more then a year since you stated Lifx will work with SmartThings. Samsung, it is probably not your problem because someone dropped the Linx integration as you were purchasing SmartThings, but it is now your baby.


(Mark) #16

I ran into the exact same thing with Rule Machine…trying to change the color on 3 bulbs and only the first one changes…I created 3 separate rules - so when I press the scene button, it fires all three rules…a pain in butt, but it works - nd I don’t need to deal with latency issues with IFTTT. I am using the ZWN-SC7-Enerwave-7-Button-Scene-Controller to change the colors…Rule Machine supports the switch and the triggers…just need 3 rules per button :frowning: – BTW, I use the 7th (bug button) to turn all three bulbs on/off – this works great (like you said in the beginning --it is a color changing problem.