I am officially stuck - Can't add A19 Hue light


(Monte Montemayor) #1

I embarked on what i thought would probably be the easiest task of my short Smart Home career. I simply wanted to add 4x Hue White A19 bulbs to my Hue + ST Hub. I plugged all 4 in and turned on the light switch, they all turned on white as expected. Every light in my house is connected via the Hue Bridge and then I connect it in ST app. So… when I hit the “+” button in the Hue App, it scans but can’t find the bulbs. Just for kicks I went to the ST App and added a Thing and I can see that it found 4 Things but not Bulbs as I expected. Just generic Things.

  • I tried this about 5 times - Nothing
  • I took them out and tried to add 1 by serial number in the Hue app. Tired a different bult w serial number - nothing
  • I EXTENSIVELY searched the internet but didn’t find anything - nothing
  • Did the same here in Communities - nothing
  • Rebooted the Hue Bridge - tried again, nothing
  • Rebooted my phone, tried again, nothing
  • Threw everything in the ocean and lit it on fire - I think I dreamed that part, not sure

Any advice?


Hue Bulb Factory Reset: SOLVED if your Hue Bulb is on a ZLL Channel
#2

Sorry, I’m a little confused.

Did you successfully add the new Hue whites to your Hue bridge before trying to do anything with them in SmartThings?

The official integration is between the SmartThings hub and the hue bridge, it’s the bridge that tells the hub about the individual bulbs.

So the first step is to have them added to the hue bridge and to be able to use them from the official Hue app.

Also, where did you get the hue bulbs? Did you buy them from a regular retail store, did you get them from a friend, did you buy them used, did you buy them in a starter kit, or as individual bulbs? If by chance the bulbs were previously paired to anything else, including another hue bridge or a hue dimmer switch, they would need to be reset before they could be paired to your own bridge.

If instead you add them to the smartthings hub before you add them to the hue bridge you’re going to have a number of different problems. However, I’m tired tonight, so I’m going to leave that to other people to discuss if that’s your situation.


(Monte Montemayor) #3

Just for additional testing, I took a lamp and plugged it in right next to where the Hue Bridge is located.

  • Tried 2 different bulbs and repeated the steps above, including trying to add manually via serial number - nothing
  • I happen to have an extra Hue Color Downlight and extra Hue White Ambiance. I plugged them both in and they both connected immediately
  • I tried the White A19’s again - nothing

Frustrating.


(Monte Montemayor) #4

No, since I’ve only used Hue lights in my house, I always add them first to the Hue bridge but it can’t find them. But just for kick, I wanted to see if the ST bridge could find them and it did but only as “Things” and not light bulbs. [quote=“JDRoberts, post:2, topic:84933”]
Also, where did you get the hue bulbs?
[/quote]

I bought them from Best Buy, which is where I’ve purchased all of my gear, except for the Iris Motion Sensors, of course. I bought 4 new factory sealed individual bulbs.[quote=“JDRoberts, post:2, topic:84933”]
However, I’m tired tonight, so I’m going to leave that to other people to discuss if that’s your situation.
[/quote]

Rest up. I appreciate all of your help to me and so many others.


(Realy Living Dream) #5

Now you have the “FUN” :monkey: that the bulb is linked to ST hub ( even if as a thing) so you need to reset it before Hue bridge will ever find it


(Monte Montemayor) #6

Is Lampstealer the only way. I downloaded the Mac version of this and of course… it says Bridge not found, even though I can see it on my home net and ping it from Terminal. :frowning: Any other way to do this? Shame oh Phillips for not making this MUCH simpler to do.


#7

Lampstealer may not work. If smartthings shifted your bulbs to A ZHA channel which is not also a ZLL channel.

My personal suggestion would be to return the bulbs to Best Buy as being unable to pair and starting over with new bulbs. And this time pair them to the hue bridge First before doing anything else.

If you do really want to go forward with these particular ones, you can buy a Lutron connected bulb remote and reset them that way.

Already a lot of discussion in the forums about why that might be, Hopefully someone else can direct you to those discussions. But it would be a good idea in any case to check the IDE and see what zigbee channel your hub is on.

And I know this is frustrating, but this is not Phillips fault. Their devices are certified as ZLL not ZHA. When you tried to pair them directly to the smartthings hub, you may have shifted them to a ZHA channel, which is a situation that neither Phillips nor SmartThings support can help you with.


#8

Or, since they are white bulbs, you can go into the smartthings IDE and change the device handler for those bulbs from a “thing” to a “zll dimmer bulb” and just leave them connected to smartthings until you can get a lutron connected bulb remote to reset them. They will not be controllable by any hue apps tho.


(Monte Montemayor) #9

OK folks - I feel I am close but need help with the last mile here. I was able to access the Hue Bridge via the web API.

https://developers.meethue.com/documentation/getting-started

I was able to get a USERid, etc, issue the get command and see all of my devices. But from here, I just can’t figure out how to reset the Hue Bulb so my Hue can find it. I feel this is incredibly harder than it has to be to reset a Hue Bulb to factory fresh. Any help would be greatly appreciated.


(Monte Montemayor) #10

This thought occurred to me but I am awfully suborn when it comes to letting “technology win”. grrrrrr


(Monte Montemayor) #11

I think I am going to go this route - need to research it. Thanks for the lead.


(Monte Montemayor) #12

ok - I think this is what I am looking for, a post from JDR that explains this. I think it’s worth the investment to try/learn.

And here is the YouTube on exactly how to use the Lutron Remote to actually factory reset the bulb.


(Monte Montemayor) #13

I think that is part of why I am so frustrated by this. I didn’t try to pair them to ST! I tried to pair 4 of their own factory fresh bulbs with their own product (Hue Hub) with their own app (Hue App). I have done this successfully with 20 of their bulbs, without incident I might add. When that didn’t work, I checked the ST app to see if they showed up there.


(Monte Montemayor) #14

Hey everyone - I have this solved finally. Thanks everyone for the help and the leads that led to finding a way to solve this bugger.


#15

What zigbee channel is your SmartThings hub on? You will find this information in the IDE by selecting your hub and then looking for the zigbee entries.


(Monte Montemayor) #16

Zigbee Channel 24


#17

OK, that’s a ZLL channel, so you lucked out. :sunglasses:


#18

When you chose “add a thing” in the SmartThings mobile app, you started the pairing process.

If instead you had just opened the things list and looked at it, you would not have seen your bulbs there, and they would not have paired to your smartthings hub.

Anytime you choose the “add a thing” option you will start the pairing process for any device within range which is in pairing mode.

I personally think they should have more of a warning message about that in the mobile app and give people a second chance to bail out, because it can definitely cause some unintended consequences. But that’s how it works. Tap “add a thing” and things will be added if possible.


(Nick Cairncross) #19

Just had this trouble so thought I’d share, 2018 style…! :smiley:

I don’t know much about this stuff but I got myself into a pickle when I bought a Hue dimmer switch and paired it to the already-detected ST bulb. ST lost it (and thus Alexa) but the dimmer remote worked just fine! I then found this method to factory reset your Hue bulb using the dimmer remote: https://www.youtube.com/watch?v=qvlEAELiJKs. Short version: hold near bulb. Hold On AND Off for 12 secs.

Worked for me and I can now add the device back into ST. All good.

Moral: Buy a Hue Bridge. Don’t pair a Hue remote if no Bridge :slight_smile:


(Monte Montemayor) #20

Glad it worked out for you. There is a bit of a learning curve with this stuff. It seems that making these mistakes is what has helped many of us learn more. :slight_smile: