HVAC, Smartthings, and sensors request

hvac
ecobee
thermostat
fan

(Philip Williams) #1

Soo i am looking for some help. I’m not entirely sure if im even in teh right place. I’m wanting to create a custom rule with my ecobee temperature sensors that if the delta between 1 room vs the others is greater than x then teh HVAC recirculating fan will turn on until either the delta returns below x or the HVAC turns on to cool/heat as required.

I currently have an ecobee 3 with 4 remote sensors


(Jimmy) #2

I don’t have an Ecobee, but do their remote sensors show up in SmartThings as devices?


(MarkTr) #3

Try the Ecobee Suite - if nothing else, it will expose the sensors so you can use them for automation in WebCORE or a custom smartapp
. @storageanarchy provides fantastic support.


(Barry) #4

The Ecobee Suite I am maintaining may well provide exactly what you want. It will expose the sensors, and also it includes a Smart Circulation Helper SmartApp that will increase/decrease the circulation time (minutes per hour) when the delta temperature in 2 or more rooms (that you select) exceeds a specified delta. There are 7 other Helper MartApps included for various other functions.

It’s a lot to consume, so I suggest starting with the documentation linked in the thread below:

Enjoy!


(Philip Williams) #5

I appreciate this. This is perfect. The only issues I’m having at the moment is the hold. When i was using ecobee connect I was able to use a “Home” scenario it would set thermostat to 68/74, “Goodbye” would set to 64/76. I have to have a mode on my thermostat, it won’t let me leave it blank) so I set it to 24/7. But now it doesby change automatically. I know I’m doing something wrong just not sure what. If I manually select a smartthings scene it changes as expected.


(MarkTr) #6

Use the Mode/Routine/Program Handler helper app and choose either Routine (Goodbye / I’m Back) or Mode (Home / Away) to trigger the appropriate EcoBee program.


(Philip Williams) #7

So im still trying to learn all tge terminology and features. Where do i go for this.

Thanks for the quick reply


(MarkTr) #8

Assuming you have everything installed already - go to the Ecobee Suite Manager in Smartapps, select Helper SmartApps, then pick New Mode / Routine / Program Helper and follow the prompts.


(Philip Williams) #9

Once again thank you for the quick response. Ive just gone through and created a few programs. The only other thing ive noticed is that the display on the main thermostat screen (in smartthings) will randomly disappear and stop showing thr temperature. I have tried the double refresh I read for a previous version (1.2 I think) but it doesn’t always come back. Either way I’m able to “balance” the temperature in my house better now that i can circulate the fans better. Now just trial and error I guess.

Once again thanks Barry for the app, and thank you mark for being tech support


(Philip Williams) #10

So noticing a lot of short cycling now…is there anyway to stop this within the app?


(Philip Williams) #11

Apologies for posting so shortly after each other…i have now got my display back within the thermostat thing screen (smartthings) and the fans have come on for longer than 30secs. I looked at the debug log and about the same time that I got full functionality back I also got a connected to smartthings in my recently tab. Are the 2 connected you think?


(Barry) #12

The app doesn’t actually turn on the fan or the heat/cool - it merely sets parameters in the thermostat to define when the HVAC equipment runs.

It is more likely that you have more than 1 SmartApp setting parameters, or that you perhaps set the change frequency in the Smart Circulation Helper SmartApp to low - the default is 10 minutes I think, and the minimum should probably be 5 minutes.

All that said, it seems like you are all set for now. In the future, please post your questions/feedback on the primary thread here: [RELEASE] Updated Ecobee Suite, v1.4.0 (Free)

Enjoy!