Huge Lag/Unresponsive Devices (UK)

Hi All,

I have just had my house rewired and as such thought it would be a good time to bake in some smart tech into what is, essentially, a 100-year old pile of bricks. Rewire happens, all goes well and new kit is installed. I opted for Qubino DIN Dimmers (looks very nice and centrally controlled, no need for physical light switch) for control and the Aeotec Wallmote Quads as switches. I have some other devices which are mostly working OK but the real problem I have is with my lighting.

When I press a button on the Aeotec’s they flash, they vibrate and then nothing happens. If you are lucky after about 10 seconds you might get a light coming on. I have been doing some investigation as I am new to Smartthings and have completed a bit of troubleshooting…

  1. I have run the Z-Wave repair numerous times. It was reporting orphaned devices so I have cleared them off by force removing dummy devices with matching network ID. The test now completes without complaining at all.
  2. I have changed the device handlers for the Qubino’s from their custom DTH to a generic Z-Wave Metered Dimmer type. Exactly the same functionality but now we have local execution. THis has solved 99% of problem with the Qubino dimmers. They work prefectly from the app now and also Alexa seems a bit happier (would report non responsive device although would actually turn the light on or off)
  3. Have enacted QoS on my network. I have full Cisco Meraki network at home (FW, Switch, AP) and as such I can be quite granular with QoS. Anything from the Smartthings hub is prioritised above all else and forwarded ASAP (EF48 for the network geeks among you)
  4. Used enhanced monitoring on my WAN connection… This is the interesting bit and explains why step 2 sorted so much out. I have between 25-35% packet loss all day long and between 50-80ms latency which can spike to 2500ms if the line is under heavy load.

I think my problems stem from having about 25 orphan devices (now fixed) and also having an incredibly unreliable internet connection. I have solved the orphan devices and by moving the DIN Dimmers from cloud to local execution has fixed that. So it looks like the internet would be the thing to fix and everything else is a workaround.

Having just been quoted £12000 to get fibre installed to my property the workaround is starting to look pretty attractive… is there a local exec DTH that will work with the Aeotec Wallmote Quad? I don’t need the generic one to do everything, just register the button presses. I can change it back to the cloud based one if I need to change any device specific stuff and revert to the generic one after I assume?

To clarify, turning a Cubino dimmer on and off from the ST App takes less than a second and works brilliantly. Using the Aeotec Wallmote Quad to do it results in a long wait and that is if it does it all. Pretty sure internet is the problem so need something to process the button presses locally if possible. Failing that if anyone works for BT I could do with some Fibre in my house!

Would a group association help here? I don’t want to do direct association as it would remove the whole point of having a hub but surely there is a fudge to sort out the lag?

Thanks
Jamie

Hi @31noble,

I don’t have any of the Aeotec Quad devices, but I have a few of their old minimotes, and those do run local. What would happen of you changed the DTH for the Quad to “Aeon Minimote”? I know those are completely different, but if the button presses work to turn on a light fairly quick compared to your custom DTH, this could be a possibility for you.

Hi John,

Ah brilliant, thanks for confirming. I have just had a look and the minimote has the same buttons and functionality so fingers crossed it works. I will have a go tonight and see what we can do, I don’t mind losing a little bit of functionality but I do mind if I am walking around in the dark!

All in all, Smartthings looks pretty decent, its just shame I wasn’t prepared for the tweaking. I have gone from ‘this is brilliant’ to ‘im gonna pull it all out and replace with Lutron’ to the current ‘this isnt so bad at all, maybe I will buy that fridge’ in the space of ten days. Still better than the LightwaveRF setup we had in our old house!

Thanks again
Jamie

1 Like

I’ve been with ST since the very beginning and have gone through that thought cycle so many times I’ve lost track!

I’m actually very happy now with my setup, but it wasn’t that way for some time. For the first time ever I’ve gone for weeks without a problem, and I attribute that to performing a massive purge of almost all my zwave devices and moving almost completely to Zigbee devices. In fact, I just returned from a 2.5 week holiday to Greece, and I did not have a single issue with ST while I was gone. I was able to control everything remotely, monitor everything, and all my automations worked flawlessly the entire time, even through a power outage in our neighborhood.

I use to have close to 300 devices, mostly zwave; but now I’m down to less than 20 zwave devices and over 240 zigbee devices. Performance is spectacular, and all my zigbee stuff is local to the hub. Knock on wood, but so far the transformation to zigbee for me has been great.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.