Hue Lights Controlled by Ghosts? They Turn Off Every Night at 10pm. HELP!

Unplugging the smartthings hub is more complicated because there might be a cloud to cloud component, to be honest I don’t know how the Hue integration works anymore.

If it happens when the hue bridge is disconnected, then, yes, it isn’t any of your automations on any platform because they all go through the hue bridge not directly to the bulbs.

Check the IDE and see what zigbee channel your hub is operating on, and check the Hue app and see what zigbee channel your Bridge is operating on.

Hi JDRoberts,

Hub is on channel 20. Bridge is on channel 25. Is that significant? Good or bad?


Neither good nor bad. Probably not a contributing factor.

I’m back to thinking It’s probably an automation somewhere.

I had the exact same thing happen to me and it was Alexa. I had changed an automation command and Alexa was still picking up the old automation. Go into Alexa a delete references to those bulbs and then rediscover them.


Hi Scbart52,

Thanks for the insight. How did you determine it was Alexa? Where was the automation command that you changed - Alexa also? What did you change that caused your lights to do this?

Sorry for all the questions but I can’t stand not knowing what it is.

Even odder tonight - my lights went off at 10pm and I immediately turned them back on (it wasn’t even a minute - it was still 10:00, not 10:01) and then then turned off again.


I was like you. It was driving me crazy and I just finally figured it had to be Alexa. So I deleted the bulb and the scene from her and then went back to my IRIS app and renamed that bulb Casper, after the friendly ghost, and that fixed it. Then I went into Alexa and rediscovered the bulb to set it back up there. I have that bulb and another included in a scene and when I changed the time the scene activated is when the problem started.


After you renamed the bulb and rediscovered it, did you keep the bulb name Casper?

I ask because I deleted the problem bulbs and some related scenes from Alexa and then rediscovered them without renaming them. Sure enough, the lights turned back on again. Perhaps I overlooked a scene or two in Alexa for removal?

My new plan is to delete these bulbs in Alexa right before 10pm to see if the lights still turn off. Then worry about rediscovery afterwards.

Yes, I have now just named the bulb what it was before and I am still fine. What I found out with Alexa is that when you do changes in your Smartthings app, changes that Alexa picked up on already, that these changes don’t necessarily change in Alexa. So, sometimes I will just go into Alex and review what is set up there and delete stuff that shouldn’t be there anymore. This especially was the case when I moved over from the Lowe’s IRIS system to Smarththings. The IRIS stuff was still all in Alexa even though I had deleted everything from the IRIS APP and then deleted the APP.

There could be a couple of different things going on.

First of all, it can take echo awhile if you were depending on the automatic discovery system. Saying “echo, discover new devices” will force a refresh, but even that doesn’t give you an instant update because there’s a cloud component to the integration.

So for testing, I would do the changes at least two hours before just to be sure they get picked up in the cloud and then do the Discover phrase 15 minutes before the actual test.


If I understand you correctly, you’re suggesting deleting the problem bulbs from Alexa 2 or more hours before 10pm, the problem hour. That is to give Alexa enough time to clear them from whatever memory or cloud they are kept, correct?

What is the significance of adding them back 15 minutes before 10? I would have thought leaving them out of Alexa completely before 10pm would be able to show / isolate if the issue is with Alexa or not. Does that not accomplish that? Perhaps I am missing something.

Thanks for your input,

I agree, I personally would do one step at a time. So just take them out altogether and then see what happens.

But you had previously suggested renaming them right before 10 o’clock and my point was just that if you are going to rename them, give it some time to repopulate if needed.

Well I’m thinking about it, have you yet tried unplugging the Hue bridge all together before 10 o’clock and then waiting to see if anything happens with the bulbs?

I have not tried that yet. Should I try that before removing everything in Alexa? I am a stickler for proper procedure.

At this point, it’s just a matter of personal preference. Unplugging the Bridge would confirm That the problem is likely a rule somewhere, but it wouldn’t tell you anymore than that and it wouldn’t fix the problem.

If the rare situation occurred where you still had the lights coming on at 10 even with the bridge unplugged, then you would know that it was local interference from something. So you wouldn’t have to go through all the Amazon checks at that point. But again, that would be a rare situation given the exactness of the time when the problem occurs.

If you start by working through the Alexa options, you’re more likely to fix the problem during the troubleshooting.

Everybody has their own fieldwork style. I tend to work with the hardware first, but that’s not a best practices decision, it’s just the way my head works. :sunglasses:

So I removed all the bulbs, scenes and routines from Alexa that I thought could be the culprit. I did this at about 7:45pm. Sure enough, the bulbs turned off again.

Note, I did not delete everything from Alexa. My upstairs bulbs remained. Any chance two hours is not enough time to drop the, from any cloud memory?

Should I just delete everything from Alexa, including routines created in Alexa?

I guess I could also try the nuclear option and just disconnect the Hue bridge to see what happens but I really want to get to the bottom of this before having to do that.

In Alexa, you can simply disable them. open each routine and at the top of the screen you have the option to disable that routine.

Going back to my 1st post - I mentioned it is most likely an automation, routine, smart lighting rule or piston.

In the STSC app, you have the ability to disable any custom automations and smart lighting rules that you have created. You can also disable (pause) any pistons you have created. Plus you have routines in Alexa. So I would recommend disabling in batches until you find the offending one.

1 Like

Ah yes, you mean disable the Alexa routines, right? I forgot you can do that. Thanks for the reminder!

1 Like

This might seem like a silly question, but what is the STSC app? I ask because I use the SmartThings Classic app - the app with the blue circle. I also have installed the other SmartThings app - the one with that has what looks like a hub for a logo. I don’t really use that app, though. Is it one of those or yet another one?

Also, where in the app can you disable automations? I looked in Scenes, Routines, SmartApps, and the apps within SmartApps but don’t see any disable options in the SmartThings realm.


STSC is The new app: “smartthings (Samsung connect)“

If you are seeing “routines,” you are in the classic app, and you can’t disable smartapps in that one.

I wouldn’t consider unplugging the hue bridge a “nuclear option,“ as you don’t have to change anything else and when you plug it in again everything will still be there.

Going through the various automations and routines to me is much more nuclear since you actually are having to remove things and maybe put them back again later. :sunglasses: