Hue hub v2 drops Offline in Smartthings (hub v3)

Hi. My first post here.
I have a rather new (1-2yrs) Smartthings system in another town which I use remotely and randomly visit the location.

The system is rather basic, Smartthings (ST) hub v3 with about 10 sensors and a couple Smartthings/Aeotec cameras connected via Wifi. There is also a Philips Hue Hub v2 and a couple Hue bulbs. There is a mobile Lan switch with Wifi and 4G connection to internet. The Smartthings hub v3 and the Philips Hue bridge v2 are connected to LAN switch with RJ45 cables.

There is also some automation configured in the ST system. And I have a power switch timer that will power off some components for some minutes once a day (precaution you know). Earlier it was only the LAN switch but a couple days ago I changed it to switch all LAN switch, and both hubs to help with my issue I am describing here.

The system has worked fine for 1+ years but couple weeks ago I noticed the Hue hub and bulbs went offline permanently.

As a remote fix (after the automatic LAN switch power break did not help) I tried uninstalling the hue hub. Then I realized I need to be locally connected to location Wifi to work with Hue so I stopped trying until I could go to the site.

I had installed the Hue App and I was able to control the Hue bulbs with it when I was back on the site some days later. Otherwise the Smartthings system was working fine all the time, including the Wifi connected cameras.

Somehow I was able to get the Hue hub and the two bulbs back online after re-installing them. There might have been some unclarity for me if I need to allow the Smartthings to use the Hue devices (via logging on to Hue service) but I think it was not necessary. Sorry can’t remember exactly what I did to make it work.

Anyhow at the end I was able to control the Hue bulbs from ST application, just like before.

I left the site for couple days and during that time I noticed the Hue hub and bilbs went offline again without possibility control them from ST.

When I was back on site I was able to control the Hue bulbs fine using the Hue App. I tried rebooting various components (LAN switch, ST hub, Hue hub) without help for the Offline issue. I did not want and have time to un/reinstall the Hue because I first wanted to find a more permanent fix or the reason for the issue.

Now, please help me. What should I check and/or do to get this solved? The problem is I need to drive 100+ miles/km to get on site. So I’m gathering information at this point.

The ST hub FW version is 000.048.00005 or such.

Any other info that would help you?

check this thread for information on this topic:

Ok and thanks. I had already seen that thread but without knowing better was unsure what ”UK” means there and thought it is something different, like perhaps a United Kingdom version of the hub… ;-). So then just wait I quess. Luckily nothing important depends on that functionality at the moment.

Hi again. Greatly appreciate your help so far.

I’ve read June part of the "UK v2… - discussion and was going to check my hue driver version. In my devices I only see one Hue box/tile/whatever-fancy-name-it-has and the info in there is:

On top it says “information”. Below Philips hue it says “Connected to device Hub”. Then at the bottom “driver version 2.3.22-2”

Is this Hue bridge or just “Hue” and where do I see the date for the driver? I assume the x.y.z-a at the bottom is the version, not a date (although in finnish notation style that could be interpreted as a date as well). If it was a date it would mean March 2nd 2022 and then followed by -2.

As I’ve hopefully said I’m not 100% sure what kind of integration I currently have between ST hub and Hue hub…

As already said, the system un question is on a remote location and I don’t know how to connect to Hue remotely. If I DO open the Hue app, it says:

Where “Tila” = status says “Hue Bridge is not active”. “Ohjelmisto” means FW or SW.

(Sigh… I should be on summer vacation from daily IT work - embedded systems - but this definitely feels like being at work ;-)).

Few additional images so you know what I’m talking about:

And by the way, in case you need my ST account email it is different from the email I have registered here with.