Hub went offline after rebooting the router

I figure out what is the problem for ASUS routers:

“Enable Internet Detect” must be off for the Hub to be able to recover from an internet outage.

I was having the same problem with an Asus router running Asuswrt-Merlin firmware. Couldn’t find this setting for Enable Internet Detect. I noticed that after a router reboot the Smartthings hub was ending up with a seemingly random LAN IP as the DNS server address. After reading the other thread mentioned above about AT&T Uverse problems, which also references DHCP problems, I landed on the following fix. In the LAN -> DHCP Server settings I disabled “Advertise router’s IP in addition to user-specified DNS.” This was Smartthings never gets any LAN IP as a DNS server. I had to my router, then reconnect from Smartthings, then reboot the router again in order for the change to stick with Smartthings.

dns