Hub v2 causing DHCP issues


#1

Hello, I’m new to the community and SmartThings in general. I’ve had my Hub v2 for about 3 weeks now and ever since I plugged it in, I’ve been having DHCP issues on my local LAN.

A little about my hardware:

  • 10 hue bulbs with the phillips hue hub
  • Harmony Hub remote
  • 3 SmartThings sensors
  • raspberry pi with homebridge for Siri control
  • Hitron router (from my ISP)

A little about my setup:

  • Sensors in the closets to turn the hue lights on when the door is opened
  • Lights in the living room the turn on/off at sunset/sunrise

All-in-all a very basic setup at the moment and now the problem:

  • Day 1 I received a message saying the hub is offline so I looked around and realized my wifi was out
    ---- Solved by rebooting the router.
  • Day 3 I received this message again, my wifi was out again
    ---- I put a static IP/dns on my laptop and logged into my router to see what was up
    ---- The internet was still working, and I had a correct WAN ip and dns
    ---- The LAN clients were getting APIPA however (automatic private ip address) of 169.254.0.0
    ---- I reset dhcp, no fix, I unplugged the SmartThings hub and reloaded my router
    ---- Solved, everything is back up (I left the hub disconnected from my network at this point)
  • Day 10 I haven’t seen any further problems now that the hub is disconnected
  • Day 11 Looking through this community, people advise to:
    ---- Use reserved dhcp leases (this didn’t change anything)
    ---- Increase the dhcp lease time, this improved the situation but now the problem simply occurs less frequently (every third or fourth day instead of every day)

So… now I’m here asking the community because so far the SmartThings hub v2 appears to be messing with DHCP on my Hitron modem and causing the LAN to use APIPA which breaks wifi in my house.

What else can I say?

  • I only have a laptop, no wired PCs (only wired computer would be my raspberry pi and it is affected as well, with a static IP, it works during these outages as well)
  • If there are no solid answers, I may need to bring my work laptop home and do a wireshark capture although I’m not excited to sit around and wait for this to happen with wireshark running.
  • Does anyone know if SmartThings is aware of this issue? Maybe a fix will come out soon?

#3

The ST hub is physically plugged into the router, maybe 2 feet.


#5

Is there a correlation that you’re thinking of?

I can only think of 2.4G interference problems maybe.


(Bill Stefanelli) #6

When you say you unplugged the St hub do you mean powered off or Lan disco? I can see how proximity interference would cause wifi issues but not router configuration issues. Not that I have a solution, though I’ve seen bad cables cause weird problems. Try swapping it.


(Bill Stefanelli) #7

Also just occurred to me that the st hub may be your only direct lan attached device? If so check your port settings maybe something will stand out, like protect features.


(Daniel Ionescu) #8

Sounds more like an IP address conflict or IP pool too small in the router.
Or if you have 2 devices with same network name. Check name of Harmony hub and name of ST hub.
Hub is only a client to the router and it uses whatever IP router gives out.

Never heard of this issue before.


#11

I mean LAN disconnect, I left the power to the ST Hub connected (while I had no issues)

Physically, I have a Phillips Hue hub, Raspberry Pi, NAS, and the ST Hub

I agree, however at this point I would say it is very likely that the ST Hub is interrupting the dhcp requests from other clients resulting in a timeout (IE: No dhcp address to be assigned). I say this because clients on my LAN will assign themselves 169.254.x.x which only happens if they can’t reach the dhcp server (in this case is my Hitron router)

PS - Just learned how to quote text, very cool!


(Michael Hess) #12

Your wireless is bridged to the LAN on the router. There should be no way for a physically connected device to interrupt DHCP requests on a simple broadcast domain like that. This would be a failure of the routers DHCP server. But that could be caused by a bug in it if receiving a malformed DHCP request from another device (ST hub) though that’s not likely.

The auto IP you get on other devices is, like, you said, because the router is not returning a response to the initial request, it can’t be intercepted or changed though.

Can you view ARP entries in the router? Verify none of the devices are all zeros (arp -a on laptop after a ping), and that you get successful pings to each device simultaneously. Do a -t ping from a separate command window for each device from the laptop.

You could run a temporary DHCP server on your pi or laptop also, to rule the router out… Just disable it on the router first.


#13

Agreed, this seems unlikely aside from a mac spoof of MITM… to be honest I’m not sure what the ST hub replies with so ‘how’ it’s messing with the dhcp on the router is still a mystery (thus this post).

The router is very basic, it does an arp via a ‘connected clients’ utility which shows the mac/IP pairings of each connected device, none with 0’s. I’ve checked this during the issue as well and it shows nothing in this table (except my laptop after I’d assigned a static IP to it)

Actually, this is an interesting idea… I’ll be able to see output/logs when/if issues occur in the future. Excellent suggestion. Thanks Michael!


(Bill Stefanelli) #14

But only when connected via the LAN which points to a possible connection issue. I say this only because there are thousands of people connecting ST hubs to LANs without issue. The behavior you describe, that it works for a period of time before the dhcp issue occurs sounds like a dhcp resource problem. Maybe a router bug due to the number of physical connections. I’d try to swap cables, try a different port (can you remove another device for a while to test?) and lastly contact the vendor for any known bugs or firmware upgrades.

This (https://itunes.apple.com/app/apple-store/id922793622?pt=814382&mt=8&ct=how_i_email) is how I Email now


#15

Update:

  • DHCP server on my router is disabled
  • DHCP server on my Raspberry Pi2 is enabled
  • I chose a different subnet to ensure I could see when everything renewed from the RP2.
  • So far working like a charm, I’ll keep an eye on this and see if I have further issues.
    If I do, I’ll point back to the ST hub
    If I don’t, I’ll still blame the ST hub lol, but obviously there is some issue between the ST hub and my router.

Side note:

  • I’ve had this router up and running with maybe 10 things (phones, laptop, tv, apple tv, android box, etc) for maybe a year without a single issue until I plugged in the ST hub. Does this mean its the hubs fault? Not necessarily, but it does make it look suspicious.

#16

Day 3 - still no issues… Sounds like DHCP on the Hitron router has some issues. I’ll keep my DHCP server on the Raspberry Pi and call this one.


(Robert C) #17

I’m having almost the same issues. My Hitron modem works fine until I plug in the ST Hub. Almost daily power cycling the modem, and 5G devices have a hard time connecting if at all, the moment the ST Hub connects. My ISP helped setup an IP Passthrough, replaced the modem, and provided all new lan cables. This helped significantly. But I’m still needing to power cycle maybe once every two weeks. And my computer won’t connect to 5G when the ST Hub is online even with the passthrough. The 2.4G works fine tho. I’ve read on my ISP forum that others gave up on the Hitron in favor of Arris and Cysco modems. Any help would be appreciated. Thanks!


#18

Wow. This brings back memories.

Ultimately I was never able to solve this issue and chalked it up to the ST hub causing some kind of bug that breaks dhcp on the Hitron modem. My LAN ran well for a year or so with the raspberry pi acting as my dhcp server until I upgraded to the arris XB6 and turned off my Pi. It’s been around a year I think with the XB6 and no issues.

In the end the only solution I can offer is to bypass the hitron…

  1. Bridge the hitron (turns the hitron into a modem, no router) and buy your own router
  2. Turn off dhcp and create your own dhcp server like I did
  3. Replace the hitron with XB6 (offers better integrated wifi anyway)