SmartThings Community

Hub Firmware Release Notes - 25.26

They have moved on since programmers can’t seem to get anything working it seems to me. SmartThings was then actually was working decent for a very short period followed by the current decline is getting aggravating. It seems like they try something & when it doesn’t work move to something else and no thoughts to customers who have spent a lot of money on current products.

Polite request for any news on this please.

Thanks

2 Likes

I second the polite request. That would be great.

Out of curiosity, my new V3 hub shows firmware 25.27, while my V2 hub still shows 25.26.
Both exhibit this same problem.
But I’m wondering whether Smartthings (or someone else on this forum) can confirm whether different firmware updates are released to V2 v V3 hubs, or are both hub versions treated the same in this regard?

I too have .27 on V3 and .26 on V2 and this is how it should be, as described in post above this one.

What is the NetworkSecurityLevel for the devices that you try to change their configurations?

Hey, Sorry that I cannot give an exact date, because things are fluid but we are looking at mid to late May.

2 Likes

All of my Fibaro (Dimmer 2 and Single Switch 2) devices show a NetworkSecurityLevel of
ZWAVE_S0_LEGACY

Same for the device I “moved” to my V3 hub for testing.
Should it be something else? How would I modify the NetworkSecurityLevel?

Well, Let’s continue this conversation in the PM.

Are you confident that the problem lies in code changes to the back-end cloud server (and/or that code’s interaction with recent 25.26 and 25.27 firmware)?

Is there a reason you cant “roll back” those changes, as was done in early March before the 25.26 update?

Finally (and perhaps more importantly), is there any reason to migrate (or not to migrate) devices from V2 hub to V3 hub?

I am leaning toward waiting until you resolve this issue in mid-late May since I can work around the “sync problem” temporarily by using Z-Wave Tweaker to change/sync the parameters.

By the way, does anyone know why the Z-Wave Tweaker workaround enables the parameter sync, while the standard Fibaro DTH does not? Does Z-Wave Tweaker avoid using the back-end cloud server?

Sorry for all the questions (and for being a bit impatient for a fix).
Just want to understand these issues a bit better.

Hello - I have recently noticed the following when trying to run a zwave repair. I have a 2Gig 3GC Panel connected to my ST setup as a secondary controller - the 2gig panel is showing error “check devices” now as well it seems to be related

Also on the 2gig panel it is showing unknown device 11 - 14. In ST I only have devices 3,4,8,9. I am not sure where 11-14 come from, and is there a way to free up 5,6,7? Or is there any reason too? Thank you for your help!

zwave%20error

I’m on 25.26 and have the same issues. Everything is going haywire and very slow to turn on and off. Sometimes just stopped working all together. .Every time I run Z-wave repair different devices show errors.

Network repair for Floor Fan [4D]: Could not delete old routes
Network repair for Sub Woofer [4C]: Could not assign new route
Network repair for Sub Woofer [4C]: Could not delete old routes
Network repair for Floor Fan [4D]: Could not assign new route

I’ve removed them and re set them up still get errors. Not sure what’s going on, but if it’s a firmware they need to fix this and fast.

So how long do we have to wait for it to be released to us?

Your guess is as good as mine.

I just got hit with this bug/issue. One of my GE switches stopped working and I guess it was a pretty important neighbor for a lot of other stuff, so basically half of my house stopped working. Pretty neat. Hopefully this can be resolved soon.

You may want to post in the most recent firmware release thread :slight_smile:

Thanks. I’m on the new firmware but I think the update is actually what caused the issues!

1 Like

Since 0.25.32 has now been released please use this thread for future comments: Hub Firmware Release Notes - 25.32.

3 Likes