SmartThings Community

Hub Firmware Release Notes - 25.26

The “disconnected” message is likely innocuous. There are three messages you are likely looking at - “disconnected”, “inactive”, and “active”.

The disconnected message indicates the hub’s connection to the cloud was closed. However, there is a lag in reporting so your hub likely disconnected and quickly reconnected but that message is still generated.

As you can imagine, receiving a “Your Hub is offline” message every time “disconnected” is reported would become quite annoying and would also likely be inaccurate. Instead, we wait ~5 minutes after your hub disconnects before reporting that your hub is inactive.

You will only get an “active” message if your hub reported “inactive” and then came back online.

4 Likes

Great thanks for that explanation. So I’m seeing 4 disconnected events in the last 3 hours. Which brings me to 2 logical questions:

  1. Is there a way to figure out why the hub is disconnecting so many times? (is it from the server end or something else)?
  2. How do I turn off the “disconnected” notifications, the family isn’t happy about getting so many messages (never had this before), the offline messages should suffice if there’s an extended issue.

Just for clarity, these disconnected events are being “pushed” to the users phone (everyone on the account). I haven’t seen them before so I’m guessing this is a new feature. Would be nice to have a way to turn them off since they keep coming every hour or so and it’s getting tiresome.

2 Likes

So you’re getting push notifications indicating the hub disconnect? You shouldn’t be receiving that unless the hub is offline for ~5 minutes. We had an issue where users weren’t receiving hub push notifications so maybe this was an over-correction. I’ll keep looking.

3 Likes

I am noticing a significant delays in my GE Z-Wave Dimmers (12xxx) reporting manual operations. This is causing delays in automations that rely on real-time events.

For example, I have many Pistons that capture attributes at the beginning of an event. Now these are not working correctly and lights are turning off or setting the wrong levels because of the delays.

Yes, I’ve done multiple Z-Wave repairs. Yes, I’ve pulled the air gap on the switches. Yes, I’ve rebooted the Hub. All yields the same results.

Here’s a simple Piston that I know worked perfect for a couple years but now is wonky. I even rebuilt it and ran numerous test to finally get to the bottom of the issue. webCoRE is not receiving the attributes fast enough. It’s taking almost 30-40 seconds before the variables change values. :weary:

1 Like

Ron, see the first post in this thread. ST have acknowledged this problem and further up in this thread they say a fix is being worked on.

There is an interim option:

3 Likes

Just notified by the ISP that there’s an outage in our area. It could have been interfering with the internet during the day.

I’ll keep and eye on it after the outage is officially resolved and let you know if it continues to happen.

2 Likes

Hi,

For some reason, I can’t control any zwave devices from the app all sudden. All started since yesterday. Is there some issues going on?

Thanks!

Cool. At least I know I am not crazy: :crazy_face:

1 Like

Brad,

Thanks for the response. It appears to be working now. I will submit a ticket if something like this happens again in the future.

I have many Fibaro double switches ZW5 and dimmers ZW5 that appear unresponsive in the last several days.
Do you know anything about this, is there a solution coming?
thank you

I know one rep here has said they have found a fix and will be released soon. Meanwhile,… alert pistons, intruder alerts are going berserk that id have to disable them…

@Brad_ST I’m getting these false offline notifications frequently (2-4 times) during the day as well. False in the sense that the internet connection is functional but the ST hub thinks otherwise. Just got one 14 minutes ago, feel free to poke around my logs :slight_smile:

I was also getting the notifications around the same time. I noticed on the 14ty around 5pm that my hub had no LEDs lit up. Everything appeared to be working but I went ahead and rebooted. LEDs are green again.

I understand that v2 Hubs running firmware 25.26 are now experiencing long delays when detecting Z-Wave device status changes that are manually (not via the app, a routine, piston, etc) performed.

It seems there is a workaround with restrictions. What is the workaround?

I also understand that there IS a fix that will be released “in the near future”. WHEN!?

I believe I’m having the same issue as well. @patrick.nelsen had said he was going to look into my logs to see what he could find.

These notifications don’t seem to be connected to the 25.26 FW – I am receiving a plethora of them for the last few days (and they all are wrong – opening the app immediately after the push notification that my hub is offline shows the hub being online). I received the “hub back online” notifications hours later once I got back home (yet was able to connect to the hub the whole time).

This is with an ADT hub using FW 20.203 (since there is nothing more recent that that available for that model…)

1 Like

my hub rust rebooted on its own and is running 25.00027. is that the latest ?

You are lucky. Mine went offline all of a sudden 15 minutes ago.

I haven’t decided yet what is more USELESS- the smartthings hub or all Fibaro devices.
with this amout of problems you should shut down this project. Smart home? are you kidding me? i’m working full time job trying to solve countless problems and one is solved there are several new ones.
The smartthings support is also useless and unprofessional.
I advice new customers to think of other options.