Hub Connected Devices Now Use Edge Drivers

My speculative guess is that it will be tied in with the virtual devices the CLI can create and this will be the local version.

1 Like

yeah, it remains to be seen how to actually create a virtual device that uses that driver. At the minimum, I assume it will used to migrate existing devices that use the default virtual switch and simulated switch DTH. There’s already a couple community created virtual device drivers that are more flexible and easy to use, so I don’t know if i’d ever use this default option.

1 Like

I don’t suppose it’ll be that different to how it was for the DTH version. Just an API call from wherever. When I was reading the code last week I noticed it has the state change flag set like the DTH does so it fits the bill for a straight swap. I didn’t think to test how the virtual switch created via the CLI behaves in that regard. I have lots of virtual devices created with community Edge drivers and I am hoping to be able to replace all of them with a stock solution.

3 Likes

You can swap stock driver now, but you want be happy with it. I doesn’t have all extras that community created have

I’m holding off for the moment as they clearly aren’t ready (and, to be fair, they aren’t claimed to be). Some, like the virtual switch, will work but others are pretty much useless as they don’t have commands. Using the API to set attributes is not a practical option. I’ll also need to have local and cloud options. Very few ‘extras’ are of interest to me.

1 Like

A post was merged into an existing topic: Hub Firmware Beta Group, get ready to migrate!

Smartthings Home Connect and Smartthings Wifi are already Edge ready. Latest update this month.

Anyone having issues with connect hub updated to latest firmware and still dont see edge drivers ?
Hub model # ET-WV520


Could be related to Thursdays ST cloud issues, which have reportedly been fixed.

Have you attempted to subscribe to any of the Beta Edge Channels from any of the Developers to see if that changes? Would be interested to see if it changes :slight_smile:

@jkp When I enroll in beta program, drivers show up as expected .

I have two connect hubs at two different locations and both behave the same way.

Thanks @Paul_Oliver . That explains many failed attemps yesterday adding Ikea button. That page says the issue has been resolved now but, my hubs still dont show edge driver option .

Where is it not appearing? The picture you shared above belongs to the “Driver” option inside the Hub

It says you have enrolled to that channel but, have you installed any driver? For example:

You need to check if your device is supported in that driver, you can check their fingerprints in the official drivers’ repo:

I ran into a similar issue myself when a Z-Wave switch, overnight, switched to Edge.

The only thing you can do is to shut off the “indicator” LED and hope the Edge Drivers support this later on.
You can manually toggle the LED setting using the “up-up-up / down” technique.
Quickly hit UP three times, then Down once.

I found I could only activate two modes:
On when off
Always off

I actually prefer “on when on” - so mine are “off” for now

Can you provide more details, please?

  • Device brand and model, this is to look for the device on this page: Catalog of Certified Z-Wave Products
  • Do you know which DTH did the device use before?
  • Which stock driver is it using?
    1. In the app, go to the device details
    2. Select menu (three-dot symbol in the upper-right corner)
    3. Tap on “driver”. There it will show the driver’s name (and other details)

I have a ton (98) of Z-Wave GE devices. All dimmer, on/off, outlet devices.
All my devices are represented on a SmartTools dashboard (I keep an eye on them constantly)

Recently, (in this very thread), I had a GE Z-Wave Paddle on/off switch for my garage light go “offline”
When I dove into the Smarthing Devices, I noticed this “Z-Wave” device (unlike 27 of my other devices) was no longer marked with a “device network ID” and had a “driver” of “placeholder”. Again, none of my other Z-Wave switches had this driver, only this one.

Unfortunately, I lost access to the switch, so I took the steps of removing and re-adding this switch to the HUB and - as expected these days - it came over with an Edge Driver. I regained access to the switch, added it to my routines, and all was well - except…

GE Switches have an “indicater” LED light. It has always been a bit finicky, but you can manipulate the LED light to do one of three things:
Always off
On when on
On when off

Because most of my light switches are in banks of three or four switches, I prefer “On when On” so you know which switches are actually “on”…

-------------------------------------------------------------(TL/DR)---------------------------------------------------------------

When this GE Z-Wave Paddle Switch moved from Groovy to Edge, I lost the ability to control the “indicator LED”. It is typically an option under “Settings” / “LED Indicator”. The new “Edge” driver does not provide this option. “Settings” in not even a menu option for Edge.

The switch: Enbrighten, GE Model # 46201
The current DTH: “Z Wave Switch” (Generic) - 2022-08-02T20:09:30:783624788

The driver before the switch?
“Z-Wave Switch” - not custom…
Details from Graph API (similar switch)

zw:L type:1001 mfr:0063 prod:4952 model:3036 ver:5.22 zwv:4.54 lib:03 cc:5E,56,86,72,5A,85,59,73,25,27,70,2C,2B,7A role:05 ff:8700 ui:8700

Have you tried @philh30 Edge Driver for GE’s switches?

If you install his driver and if it contains your fingerprints you can easily switch to his driver which has move features than the stock driver.

Installation directions are below.

2 Likes

They are working in adding the indicator light setting to the default ST drivers.

2 Likes

This worked great. Appreciate the suggestion.

4 Likes

I checked the device profile assigned to the device and there’s a setting/preference called ledIndicator with the same options as the DTH:

So, you couldn’t see that option in the ST app? (device details > menu > settings)