Smartthings Edge and code/hw requirements

I took a break and tried Hubitat for a year or so and it just is not for me. Smartthings Edge is what I needed when I left. Seeing it is here, I am trying to find out minimum specs. I have a v2 hub.

Haven’t seen official minimum specs, but so far the Beta versions are working on both V2 and V3 hubs with the newest firmware, but not the WiFi mesh models.

@nayelyz

How is it working?

Typical ST beta. It works for awhile with some known issues, then there are undocumented changes and some things that were working stop working unexpectedly, rounds of discussion, some new “known issues,” the cycle repeats. :thinking:

I should also say that some community members are doing amazing work with Edge Drivers and at least the local processing promise is real. But still, glitches.

More discussion:

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

3 Likes

Thanks for the feedback! Looking forward to getting back to one platform. I just hope I can control lights if my Internet breaks.

From a physical button, yes. They haven’t said one way or the other about the app yet. Right now the SmartThings app still requires an active Internet connection, even for devices using edge drivers.

In overall I’ve been satisfied with Edge drivers so far. Few hiccups here and there but in big picture they do work. I have 95% of my devices running Edge drivers and I can see the future very bright with the Edge architecture.

1 Like

I’m still waiting for a status tool that can indicate zwave/ZigBee routes, security status, mesh data, etc. I use the IDE all the time for that information. Until then I’m not running Edge drivers in “production.”

Hi everyone, just to confirm what @JDRoberts mentioned. Currently, you just need to check:

  1. The Hub’s hardware version (v2, v3, also Aeotec Hub)
  2. Firmware version (ST Edge should work since the 38 version but the new ones have different improvements, current: v43.4)
1 Like

Current release is 43.4, the same as beta.

1 Like