Https://graph.api.smartthings.com/hub/list 500 Internal Server Error

reset hub.
Most posts here suggest Samsung need to reset to fix the error ?

Are you logging in at https://account.smartthings.com ?

https://graph-eu01-euwest1.api.smartthings.com/ with Smartthings Account

Can you provide more details?

Are you asking if you should reset the hub? The answer would be no. Or did you reset the hub and get this error?

Or just tying to load that page and get the error? Try clearing your browser cache or using an incognito/private tab in your browser.

1 Like

Cleared Cache … no change
Login using Chrome Incogito = no change
Login in Firefox for first time = same error

Oh No! Something Went Wrong!

Error
500: Internal Server Error
URI
/hub/list
Reference Id
eab7b1ef-52ea-4202-b319-229250499b5b
Date
Mon May 18 14:08:04 UTC 2020

Report it to ST support.

I have a 4 day old ticket … hence the shout out here to try and progress …

If your location is located at https://graph-eu01-euwest1.api.smartthings.com/location/list then you want to go to https://graph-eu01-euwest1.api.smartthings.com/hub/list, not https://graph.api.smartthings.com/hub/list.

I only became aware of this issue today but a recent change is causing that 500 error when you try to view /hub/list at the wrong URL. Previously you would have seen “You don’t have any hubs yet. Please use the SmartThings mobile app to claim your hub.” I flagged this for the appropriate team.

3 Likes

Thank you for your suggestion.

Same error sadly

Are you signed into the proper account? If you go to “My Locations” do you see your location listed? If your location is listed, you can navigate to your hub via the location details page as well.