How to set vid?

Hi, All:
I set the vid as “generic-dimmer” in my DHT file , and add codes as below:

    multiAttributeTile(name:"switch", type: "lighting", width: 6, height: 4, canChangeIcon: true){
        tileAttribute ("device.switch", key: "PRIMARY_CONTROL") {
            attributeState "on", label:'${name}', action:"", icon:"st.Lighting.light13", backgroundColor:"#00a0dc", nextState:"turningOff"
            attributeState "off", label:'${name}', action:"switch.on", icon:"st.Lighting.light13", backgroundColor:"#ffffff", nextState:"turningOn"
            attributeState "turningOn", label:'TURNING ON', action:"", icon:"", backgroundColor:"#00a0dc", nextState:"turningOff"
            attributeState "turningOff", label:'TURNING OFF', action:"switch.on", icon:"", backgroundColor:"#ffffff", nextState:"turningOn"
        tileAttribute ("device.level", key: "SLIDER_CONTROL") {
            attributeState "level", action:"switch level.setLevel"
        tileAttribute("device.temperature", key: "SECONDARY_CONTROL") {
            attributeState("default", label:'${currentValue}°', backgroundColors: [])

but the view on mobilePhone keep as:

The temperature can not be displayed!
I change the DHT to the official example “Virtual Dimmer Switch”, and the Brightness is not displayed!
what should I do? who can help me?

I’d try generic-dimmer-3 as that includes temperature.

The tiles you have added will do nothing. They were used by the Classic app.

Thanks! This problem has bothered me for several days.

Thanks, @orangebucket!
@chenjun, in this Glitch project, you can see the list of predefined VIDs and which capabilities they use:

If you want to use a group of capabilities that doesn’t match any of the predefined VIDs, you’ll need to create your own Device Presentation.

Note: Please, remember to mark the post that helped you solve your question as the solution.

Dear @nayelyz,

It would be appropriate to put together something complete finally! That vid selector was incomplete at the moment when it was released and it hasn’t been updated since that.

Just an example, it doesn’t contain any vid with thermostat capability, and there are a few of them.

HI, @nayelyz , I found that the Glitch project is not working as before,Why ?

Are you getting an error? Please share a screen capture if possible.
I can see the VID selector correctly

Mostly a blank page.

Oooh, I see. :thinking: I believe it’s due to the browser’s cache; if you’re using incognito mode, it won’t load either.
Please try in another browser or delete the cache.

I have change browser from the Google Chrome to the Microsoft Edge, and clear the cache, but it still remain a blank page. And i have logged in.This is really a frustrating site

I just tried and it gave me the same issue. However searching for vid-selector worked and it now behaves.

This is the blank page I can see:

There is no place for me to enter content to search。

There is if you go to the home page.

ooh I see, you’re using the URL that Glitch gives when you click on show from the dashboard (
Try using the original URL first:
And here’s the URL of the vid-selector search as Graham suggested: