How To See Z-Wave Path for Devices?

It’s been a while since I’ve played with ST and I see there’s these new pages called my.smartthings where account.smartthings use to be. Seems like there’s a new sorta IDE but looking at where I can see the Z-Wave path like we were able to see in the old IDE.


1 Like

It’s not an IDE: it’s a new web interface to your account, what Samsung calls a “web app.” (IDE stands for “integrated development environment,” a standard industry term, which the old IDE was, and the new web interface is not.)

Technical details for your devices are available in the new web interface:

But as yet no routing information. This has been discussed in detail in multiple other threads, but the short answer is it’s not available officially at this time.

As noted below, @philh30 has created a specialty edge driver, which will allow you to get the information.

We have added the information about how to get to it to the following FAQ:

Life after the IDE: Questions and Answers


And here’s the official announcement thread for the new Web UI. You’ll see much discussion of what would be helpful route info, but also confirmation that it’s not yet available officially as of the time of this posting.

NEW Advanced User App for SmartThings Web!

1 Like

My z-wave explorer driver will show the route that ST has stored for the device. That driver should be in the channel below. I’m not up to speed on what ST does to your automations when you swap drivers - I think they get disabled but I could be wrong on that.


How do I install this? I’m sorry for being such a noob!

Thanks Brother!

All custom edge drivers are installed in the same way.

Follow the link that the author gives you

Subscribe to the channel with the hub you want to get the new driver.

Select the drivers you want to download to your own hub. These may come very quickly or it can take a few hours.

Once the driver is available on your hub, you will be able to go to the details on the device page in the smartthings app for that device and select it.

Again, please see the community FAQ, it explains all of this, and more:

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

1 Like

I’m pretty sure I have the driver installed…I just don’t know how to actually use the explorer. :man_shrugging:t5:

Am I suppose to make a virtual device of some sorts and assign the driver to it?

Open the z-wave device you want to check in the ST Mobile App, click on 3 dots in upper right, select driver, select change driver, then chose z-wave explorer.

No virtual devices are involved.

I just tried it and it worked and did not affect any routines.



Getting there! Now, how do I find out what device is [17] and then [1]? I have over 200 devices…

No easy way that I know of. You need to open the suspected devices in the API Browser+, or AWA to find the ID. A few drivers like @philh30 's list the device numbers on the detail page for Z-wave devices in the mobile app.

Device 01 is almost always the hub.

I think they added the network ID to the advanced page in the web interface in the last update, but maybe it was just a suggested feature. :thinking:

Let us know if it is there. :sunglasses:

1 Like

I agree that 01 appears to be the hub based on my limited testing.

1 Like

It doesn’t have to be, but it usually is. :sunglasses:

1 Like

Thanks for the help everyone!

I got lucky and found the device on the second page.

I had the hub in the room where the Theater fan is located so that route makes sense. The Zooz Zen20 Power Strip is what I am having issues with. I just purchased and installed a Zen72 Dimmer, which is the long range Z-Wave Plus model, hoping to make the powerstrip jump on it by excluding it and adding it back. I figured it would jump on that for a repeater because it relatively close to the power strip. Still had issue.

I move the hub twice and did Z-Wave repairs both times. I found some issues and got those worked out but the power strip is still acting up. However, whenever I put the hub close to it, it works as it should. I thought for certain that it was a direct connection to the hub.

This tells a different story.

The hub is now in the upstairs room where the power strip is and seems to be working much better but still slow.

Don’t understand how since its going all the way downstairs and then back upstairs according to the route…

I should have a rock solid Z-Wave network but this power strip is just giving me the blues.