How to reset Yale LOCK With Z-Wave from ATT Digital Life?

I now have it working just fine! I ended up taking the lock off, putting it next to the ST hub (about 2 feet away), and initiating a device exclusion from the ST app. Then I was able to unpair the lock and re-pair it to ST properly. Apparently, this was the issue… Thanks for the help!

Does anyone know the status of this question?

It sounds like ST supports the Yale locks and they work correctly, but does it support managing the user codes? This is an important feature, since I currently use my Revolv to manage user codes for a rental property and am looking to move from the defunct Revolv to ST and am trying to make sure everything I have in place with Revolv will function in ST.

Any thoughts or insight will be very helpful. Thanks

I just want to highlight what @jgm1937 stated and add some assistance to anyone migrating their Yale YRD210-ZW-619 - Z-Wave Push Button Deadbolt from one Z-Wave system to the other. This same process should work for most other Yale locks that use the same Z-wave module.

I had tried doing the exclusion at the lock itself (MasterCode + # + 7 + # + 2 + #)

I had also tried just running a general exclusion (From the Dashboard, select the three bars top left, Select, the Gear icon, under Hubs select your Hub, Select Z-Wave Utilities, select General Device Exclusion) Neither worked.

The key is doing BOTH at the same time. Put your lock into exclusion mode as above, THEN start the general exclusion on your SmartThings Hub within 30 seconds. You will then get visual and audio confirmation at the lock that it is excluded.

Have both devices within a few feet of each other for the most chance of success.

To Include, get your SmartThings hub in inclusion mode (i.e. add a device).
Then MasterCode + # + 7 + # + 1 + # on the lock and it will pair. Again visual and audio confirmation on the lock should show up.

Hope that helps someone!

I have a yale deadbolt and the module says zigbee. Will this work with the hub?? I had the deadbolt working with my security company called rogers and I don’t have them anymore.

Could i buy a zwave module??

So, I’m rather new to SmartThings, but I purchased the Yale lock and a SmartThings hub. This is my first device and I’m not sure what I’m doing wrong.

What I’ve done:
Set up the HUB and installed the app (Windows Phone)
I configured the Yale Touchscreen Deadbolt with the Z-Wave adapter
I added the lock to my network (yay!)
When I go to lock it or unlock it, it gives me “an unexpected error” (well, that’s helpful)
If I manually lock or unlock the lock, it correctly reports the status in the event history
I removed it from the network (both via the app and the lock, so that I knew it was gone) and re-added it
Still the same issue.

I know it’s connected because the status changes. But I can’t control it through the phone app.

Between posting this and getting a reply, I’ll likely have set up a dashboard app on an old computer which may or may not work. Any help or advice would be appreciated.

[I’m a programmer, so I’m fairly used to figuring out tech. It’s possible that I’ve done something completely boneheaded, but only moderately so.]

As a follow-up, I eventually got it to work. I logged into the API control panel and added/edited a device type.

First, I tried the Z-Wave Lock and the Lock Capability device types that are included. Then I tried the one from michmerr (see this thread Yale touchscreen lock device type, and initial dev experience). None of those worked for me. Finally, I added the one from yracine (see this thread: Yale locks - Remotely change codes?). This one worked for me.

I’m new to the whole SmartThings world, so I haven’t dug into the code yet to determine what’s different between the two, but I will soon. But if anyone else gets the Yale lock and gets the status events but can’t control it, try these different device types.

Can anyone tell me what to push on the lock itself to get it to talk to the Zwave controller? I’ve got 3 different PDFs about installing/using the lock and none of them mention how to get the Zwave going! The Zwave controller itself says to “push a button” on the device to get it “Included”, but what button is it on the Yale Security YRL-220-ZW-619 lock??

To include a Yale lock you have to enter the master PIN, then # 7 # 1 #

I should be in the programming guide under “network module” as “join the network”

Got it, thank you! The USB stick saw it, and when I brought it back to my Mac, the software listed the lock as a device we could connect to. But when I tried to actually sync to it from the computer, it wouldn’t connect - I think it may be too far. Will try a repeater maybe?

I too am curious if this is on the road-map or if anyone knows of a Mobile or Desktop configuration tool.

I have a Yale Touchscreen Deadbolt that was left behind from the previous owner. They got it with the AT&T Digital Life system. I have tried doing the Mastercode + # + 7 + # but it only brings up the number 3. I can’t access any of the other setting. The Z Wave Module that is in it says ATT on the front. My SmartThings Hub does not see the deadbolt and I cannot exclude it from a previous network. Has anyone had any success with getting an old AT&T Digital Life Yale lock to work? Do you think I need to replace the Module that is currently in it with a new regular Z Wave module?

1 Like

No go online get the manual and follow https://www.alarmgrid.com/documents/products/yale-yrd220
And folow the reset procedure and then the lock will be ready to install everything will go back to factory settings

1 Like

The module that comes with the Yale ATT lock is pre-programmed ONLY to ATT Digital Life. You will notice that you the option to add network is not available. You will need to change he module to the standard Yale z-wave and then it will function as norma!

Where can I get one of the z-wave modules? Yale wants $125 for one.

The module that comes with the Yale ATT lock is pre-programmed ONLY to ATT Digital Life. You will notice that you the option to add network is not available. You will need to change he module to the standard Yale z-wave and then it will function as norma!

Yes I’m seeing this behavior on at ATT Digital life lock, as well. I performed the factory reset, ran the “exit network” about ten times, but that’s all I can do. I can’t pair it with SmartThings. Time to ebay and buy a normal one.

Has anyone been successful with getting the Yale lock for ATT with smart things without a new module.

Has anyone able been able to get the Smart things app to work from AT&T Yale zwake lock.

I have. I bought a Z Wave Yale Real Life deadbolt from Amazon off a third party seller. When it came, the box and module showed it was an AT&T Z Wave lock. I did the master # 7 # 1 # and it connected right away as a generic Z Wave Lock, which has only the basic function of locking and unlocking. I am going to work on it tomorrow when I get home to see if I can get ST to pick it up as a Yake lock to see if I can get more functionality.

I wanted to add my findings to this thread if anyone came along needing help getting their Yale locks from Digitial Life to work with SmartThings.

I found if you put the Smartthings hub into “General Exclusion Mode” then try and exit the network (Menu - 7 - 3) on the lock it will work. You may have to do it once or twice, but it worked on the ones I have (AFTER I bought another module).

The trick for this lock: Put your ST hub in Z-Wave ‘exclude’ mode, then run the ‘exclude’ on the lock. (master code - #, 7 #, 3 #). Your hub should indicate success. You must do both at the same time.

Then, run ‘add thing’ on your ST hub, then enter the ‘add’ code on the lock. (master code #, 7 #, 1 #) It should then show up in your ST app. That’s what worked for me. I purchased no modules, just used the one marked AT&T.

2 Likes