How to pair the ZRC-90?

Can’t figure out how to pair the ZRC-90 with SmartThings. Any help on which button to push to get this thing into pairing mode would be great!


Should be able to add using app…

Go to things
Add thing
While it’s searching press “L” on ZRC

If needed here’s the device handler:

1 Like

Tried that 10 times last night…nothing worked.

Tried again after seeing this and BAM it worked, lol

Oh well, gremlins got me again


Thats how it works 99% of the time even for the “pros”

Your welcome

1 Like

I have tried this and can’t get it to work. Nothing happens. I am new, so there may be something I am missing. Help!

Try resetting the ZRC-90 by holding the middle ‘R’ button for 10 seconds then triple click.
Then open the Smartthings Classic app, add a ‘Thing’, then press the the right ‘L’ button.

ok so my smart things app recognizes this controller & adds it as a thing but thats it!

is there some other app/driver that actually lets u use the buttons as a trigger for the smart things app?

ive successfully connected other buttons but its almost like smart things doesnt understand that this device has 8 different buttons in it? it doesn’t acknowledge ANY of the buttons

thanks in advance. sorry if this hijacked a thread. i guess i should start my own thread…sorry in advance for being dumb &/or double posting. and thanks:) i

I have the same issue - have you received a reply or figured this out?

My Remotec ZRC-90 quit working a week ago, and I’ve followed these directions many times, but can’t get the new Smartthings app to find it. Batteries are good…lights are flashing, but no go. Any suggestions?

any suggestions? I assume the device handler is still loaded, but would not have anything to do with pairing would it?


Have you read this thread, specifically posts about new app…

Have you checked to make sure dth is up to date and assigned to device ( you may have to edit to manually assign)

Hello, I really appreciate your help. After who knows how many tries doing the 10 button reset, the new ST app finally found the Remotec scene master. I followed the link to github and copied it into a new device handler. I saved it and published it for me.
There already was a my smartapps called erocm123 button controller, don’t know if it creates it automatically or was left over from my previous install.
Under my devices, when I click on Remotec and click on events at bottom of page it tells me that buttons are pressed.

I think I have the buttons programmed to turn on and off the lights correctly…but nothing happens. Andy thoughts? And is this the wrong thread to be posting this in? Thanks again.

Have you tried to reassign the buttons? I think you will have to use webcore to assign if then actions to the buttons, it doesn’t seem to work right using if then actions within ST app

Hi Guys,
I also have the ZRC-90EU, using the new SmartThings app, the device handler recommended and Enhanced Lighting button controller. This combination was working fine until a week or so ago. Now the app shows the buttons are being pushed but, same as BrentB, no actions happen.

This appears to have co-incided with the hub firmware update but can’t be sure.

I also had a 4 button Hue remote which was working now does not…

Much appreciate any suggestions.


Yes! Mine quit working about the same timeframe. I don’t know how or even what webcore is, but was going to investigate the ABC button controller. Meanwhile I got the SmartApp called Smart Lighting to successfully turn on my light for the short term.

Yes, mine quit working as well. I called the customer service number, and all they would tell me is that the device is not supported. Not too helpful!

So, I am looking for a way to make this work as well.

There seems to be something strange here with buttons and automation routines, I also have one official Samsung button. I had an “Automation” set up using it which also quit working last week.

I added a new “Automation” also does not work.

Tried routine using the smart app Enhanced Lighting does not work

If I click on the device itself (button) home page in the new app, I have three actions I can select. Picked the top one for my office light and the button works.

Not sure if this helps but I have a SmartThings Hub v2 (2015) UK version firmware 32.00012

Now have official SmartThings Button working (unsure what happened) unfortunately no luck with my Hue 4 button or ZRC-90EU.

I had wondered about upgrading my hub to a V3, or (reluctantly) try another pushbutton brand.

My ZRC-90 is working with smart lighting app, but does not work with enhanced button controller. Does anyone know of a smart app that would control the bulb brightness? my smart lighting app does not do that.

Thanks BrentB managed to get this to work this morning myself, not sure why it did not yesterday but there we are !

Using the enhanced button controller the log at says the following when button 2 pushed for example

16:50:33: debug No events found. Possible SmartThings latency
16:50:33: debug This Event ID: d8f81e90-2374-11eb-a67c-xxxxxxxxxx
16:50:33: debug Found 0 events in past 3 seconds
16:50:33: debug button: 2, value: pushed