How does the Hub handle incoming Basic Set command?


(zraken) #1

I’m trying to work around an issue with a wall switch where it won’t report the current status when the switch state is changed using the physical knob. This device can be configured to send a Basic Set command to the Hub (node 1) via an Association. When I tried this I did not see any incoming data at the Hub via live logging.
I’m hoping the Hub is capable of receiving Basic Set and if it is how do I log it (for starters)?


(Bruce) #2

What is the brand and model of your switch? Most switches do not do “instant reporting” when switched, thanks to Lutron’s patent. There are a few that do. I don’t think an Association with the hub will correct that.


#4

Group association in zwave is exactly how people do get around the Lutron patent. But it only works if the light switch is within one hop of the hub.

Lately, though, I think this is not working correctly in SmartThings. (I suspect this is what broke the Enerwave SC7 functionality for new adds.) But I don’t know for sure.

If the switch is one of those on the “works with smartthings” official list, I would ask support@smartthings.com and let them look into it.

The following link explains how the ST hub processes the Basic Set command and a bit about group association:

Note that the hub only supports one association group for itself, but other devices should still be able to have multiple groups. More about that in the last section on the documentation page here:

http://docs.smartthings.com/en/latest/device-type-developers-guide/z-wave-primer.html


(Duncan) #5

The hub passes incoming BasicSet commands through to the device type handler like most other commands.

The “Z-Wave Switch” and “Dimmer Switch” device types handle BasicSet the same as BasicReport, so you should get a “switch is on” right away when you turn the switch on if it is properly sending the command to the hub. Live logging should show something like “Z-Wave Switch was turned on”.


(zraken) #6

So, if I have configured device #10 to send a basic set to the controller then I should see the command to the controller come back to device #10? If yes then I guess it is not working 'coz I don’t see any incoming messages.
This is the monoprice in-wall switch, I’ve been desperately trying to get the updated status when the physical switch is toggled. It does seem to accept the Association command just fine and reports back the association when queried but I am not seeing anything in the logs when I toggle the physical switch.


#7

zraken - Any luck with this switch? I’m also struggling with making it work.


(zraken) #8

I’ve given up. I did find out (by reading the Mfr string) that Aeon Labs is the OEM but could not find any documentation for this specific part on their web site. I tried setting some parameters and also tried the associations but nothing worked. The only way to get the switch state updated is by polling it, note that the smarthings “poll” does not work so you will have to write your own scheduler to do the polling manually. I’d recommend that people stay away from this switch and go with the Aeon branded version of a similar switch, I have this and it works great.


#9

Hey zraken… Not sure if you have the single or dual relay Monoprice switch… but if you have the single one, then my post that I just wrote should help you: Monoprice Z-Wave Switch