How do I get my GE switch Back?

jasco

(Jason Salisbury) #1

I have a Jasco made GE Z-Wave paddle dimmer switch. Until last week it was connected to my v2 hub for almost two years straight. Last week it stopped responding to Smartthings although it still worked manually. This past weekend I tried to exclude it but it wouldn’t respond to either an attempt via the app or api exclusion methods. I then just went into the device list in the api and deleted the item. I cannot re-add it now. How do I get Z-wave functionality back or am I stuck with a $40 plain paddle dimmer?

I did pull the air gap switch and push it back in but that didn’t seem to do anything.


(jkp) #2

try rebooting your hub


(Jason Salisbury) #3

I did yesterday for another issue and it didn’t help this issue.


#4

you didn’t give the model number but since it’s at least two years old, GE/Jasco switches are notorious for locking up as they start to get older. There’s been a number of threads here and on other Home automation forums about this. The switches will be out of warranty by the time this starts to happen, so technically they aren’t defective, but it is annoying.

The first thing to try is throwing the power at the circuit breaker, not just the airgap switch. This has been known to clear the internal buffer and restart them so they can be contacted via Z wave again.


(Jason Salisbury) #6

It is a 12724. I watched a bunch of videos about factory reset and I couldn’t get any of them to work. Does anyone have any methods that work for them? I am going to call Jasco regardless.


#7

Did you try cycling the circuit breaker yet?


(Jason Salisbury) #8

No will do that this evening.


(Brandon) #9

Give Jasco a call, they should be pretty flexible if you have tried most reset options and it just flat out isn’t working.


(Jason Salisbury) #10

Just called Jasco. They said the 12724 can’t be reset at the switch so since the issue happened around the two year mark and they have a two year warranty they are sending a Z-Wave plus replacement version. Awesome customer service.


(Brandon) #11

Glad we could help!