Unable to add Github integrations

I am running into a problem and appreciate some assistance
I have been trying to add a repository on my IDE but run into issues
When I try to add BigTalker the repository is not connecting properly
This is what I enter

This is the result

And when I try to install the smartapp it fails (Strangely it displays two apps, just fails publishing)

I also just tested with konnected and have the same result (doesnt look like repository connects)

Appreciate if anybody has some tips (naturally I tried deleting and recreating)

see the disconnect on the screen you posted? click on it, re-authenticate your github account and try adding the smartapp

Thanks, dont think that fixed it
I did that and now this is the result (all my repositories gone and my repository shows DELETE)

Appreciate if anybody has any tips. I just called Samsung (1-800-726-7864) and the person had no clue what I was talking about (IDE what?).

My github integrations no longer work at all including my own repository.

@Brad_ST I didnt mark my post a troublereport. Appreciate if you can assist (not sure how to highlight so support assist me. I noticed you have helped before). I lost my ability to add github repositories (at all)

What happens when you try “Add new repository”?

  1. It shows me the screen to add a new repository
  2. I add the repository and save (it takes me back to IDE
  3. If I go back I would see the new repository with the word DELETE next to it
  4. Also when trying to update or add a DTH it would give me an error (500 or something like that)

I’m not sure why you’re seeing errors. I added tonesto’s Echo Speaks, updated from repo, and didn’t see any errors. The local SmartApp code is now in sync with github.

Ok, I am not crazy then. I was surprised I saw BigTalker2 and echo-speaks added.
When I try to add anything, I got the results below (not properly added and shows DELETE next to it). See Ecobee-Suite for example. Same even for my own SmartThingsPublic repo


I’m not sure I understand the issue. To be clear, I don’t use the github integration and it hasn’t been updated in years.

It seems like you should be able to click Settings, enter the repo info, save, and then click Update from Repo and update the repos you added. Is your concern the Delete button? Do you want to start from scratch?

Ok, I am all good. I am pretty sure this was partly PBKAC… :flushed:
Combination of a (likely) temporary problem plus my ignorance on how things work.

I did have a problem adding BigTalker app. Error 500. I thought this was related to smartthings not adding a repository properly and that the “DELETE” indicates a duplicate repository or an improperly added repository (I added Bigtalker and then BigTalker - sounds like the same)
I now realize that the DELETE next to a repository shows if there are no smartapp/DTH associated to it.

Anyway, it is all good now and I reconnected my apps/dth to their original repository.

1 Like