Honeywell TH8320ZW thermostat install problems


#1

I picked up a Honeywell Z-Wave thermostat and went to replace my current LCD programmable thermostat. Only difference in the wiring was the need for the C line 24V. I pulled the couple extra wires out of the wall (old unit was battery powered), tested with my voltmeter, found the line, I removed the plastic for the small battery, and hooked up the wiring to match the old unit and the new unit’s wiring diagram for 1 unit cold/1 unit heat.

Except, the thermostat won’t turn on at all. Not a glimmer of life. Anybody have any suggestions? I’ve heard getting RAs from Honeywell is problematic as they require installation by a professional so I’d rather exhaust all my resources first. And this forum is most definitely a resource.

TIA


#2

chirp chirpchirp chirp**

Bueller?

Bueller?

I’m really at wits end, anybody with a suggestion of any kind would be appreciated.


(Joshua Lyon (SharpTools.io Dashboard)) #3

After inserting the wiring into the wall plate adapter, did you check the contacts that the thermostat plugs into to make sure there was appropriate voltage and that the connections were all solid?


#4

I did. More than that, I actually directly connected the ground and the C wire to the unit just to see if it would turn on. Would the button cell battery being dead prevent the unit from turning on? I haven’t changed out the battery.


(Joshua Lyon (SharpTools.io Dashboard)) #5

I’m not sure about the dead battery, but it’s worth a shot. You might also pull out the battery tray and make sure the contacts for the battery are clear of all obstructions (eg. make sure part of the plastic tab didn’t get stuck or anything):

It has been a while since I did the install, but are there different jumpers for different wiring configurations? Sometimes you’ll need two contacts on the plate jumpered to each other for different wiring configurations and removed for others.

Installation Manual for Reference


#6

My heat and AC use different transformers, so no jumper. I used my voltmeter to test the battery and it’s fine. I checked the contacts and saw no issues. I’ve tested the voltages through the harness along all three circuits (Heat/AC/Common) and everything checks out. I’ve tried two units and neither turn on in the slightest. I’m pulling my hair out.


#7

Hey man - I actually recently installed the same tstat and had the same issue. It took me a few times, but here’s what I checked that eventually worked:

  1. I have multiple HVAC units in my attic, so I had to ensure that the C line was running to the correct unit
  2. Once I correctly identified which unit the tstat wire was running to, I had to hook up the C wire on the UNIT side - it was not ever hooked up in the original installation because the original tstats were battery powered (like yours)
  3. Finally - my units in the attic have a fail safe switch that is only depressed when the door to the unit is fully installed. So, I wasn’t getting any current on the C line because that door was open and the fail safe switch wasn’t depressed. Check to make sure all the fail safe switches on your unit are depressed, otherwise, they won’t send any current through the C line to power up the tstat.

It sounds like you got 24v on your C wire, so I don’t know if that helps you at all, but just thought I’d pass it along in case it does. Hope you get it working!


(Elijah) #8

Mine arrived with a dead battery, got around to replacing it after 6 months… worked just fine untill you removed it from the wall, then you had to reprogram it.
Cant speak about the wiring issue, I went from a Honeywell to a Honeywell. did have to re-install the old one once to retrieve the program settings.


#9

Yeah, my C wire was coming from the Furnace (Oil). Does it need to be run from the AC unit? The AC was just installed about 2 years ago and is separate from the Furnace.


#10

Na- mine comes directly from the furnace.