Homeseer FLS100+ floodlight sensor

Hello, I’m new with ST hub and smartthings app.
I’m trying to add the floodlight sensor but it does not show up when I’m trying to add a new device.

I added the device handler code from Homeseer.
I tried factory reset the sensor.
I tried to exclude the device, on the smartthings app and it shows confirmation that it was excluded. Then I tried to included the device on the smartthings app and it can’t find it.
The sensor is less than 5 feet from the hub with no walls in between.

What am I doing wrong, please help.

You tried to exclude it before you tried to add it? I’m confused. Why did you do that? After you excluded it, did you reset the homeseer? Is power on to the Homeseer sensor (wall switch on)?

I read that sometimes devices come paired from factory during quality control testing. It’s a floodlight sensor which is a motion sensor/light intensity sensor/switch… But anyway I found the problem. The New smartthings app does not support device handlers. Once I tried smartthings classic app it worked flawlessly. In other words the new smartthings app sucks lol. Thanks for the reply.