HomeSeer Floodlight (HS-FLS100+) - Installation - Device Handler for Hub - Settings Question

I have successfully installed the HS-FLS100+ to an LePower LED security light. I followed these instructions:

I had to use a file to make the opening in the base large enough for the sensor.

To get more control of the sensor I installed a Device Handler to my SmartThings Hub using these instructions:

However: The settings associated with the device do not seem to make any changes to its operations. I can change the settings, but with motion activiation, the lights stay on for 3 minutes, regardless of what setting I have selected.

The code for the Device Handler has text that appears in the settings that says, “Press Configuration button after changing preferences”…but there is no button for Configuration.

Has anyone had success using this code as a Device Handler for the HS-FLS100+? Were you able to adjust the settings through the ST app, or did you have to modify the code?

You’ll only find that when using the Classic app.

If you’re changing settings in th e new app, and they don’t work, then the DTH needs to be modified to have an Updated method included, or at least kick off the Configure method.

Edit: looked at their code just now. The Refresh tile in the Classic app kicks off Configure. There is also an Updated method, which should get called when making changes to settings for the device in the new app.

Watch Live Logging for errors when doing all this.

1 Like

Thank you for your response. I am not a programmer/coder and the extent of my current knowledge and confidence level is currently limited to installing the code and device handler.

I will have to do more research and studying to understand how each part of the code works before I can begin to modify it.

Again, thank you for such a quick response. It is good to know the reason the Settings don’t update.

1 Like

I just installed one of these sensors and am having trouble including it in my network. When I do include it my system recognizes it as a contact sensor not a switch. I tried to find the device handler but it appears the link to the handler and instructions have been taken down. It seems may be stuck can you provide any advice as to how you were able to get your sensor included in SmartThings? I have a gen 2 hub.

I am surprised HomeSeer took down the link for the code. I have attached a link to the code I used to add to SmartThings Groovy IDE. Note: I reached out to HomeSeer a while back as the new SmartThings app doesn’t update setting changes to the light from the app. I have been told that in the classic app the settings function does work. For now, when I want to edit settings for the light, I have to go into the ST Groovy IDE and edit the settings in the code.

Here is a link to a post of the original code that was on the HomeSeer page.

Thank you. I will give this a try and let you know how it goes.

Thanks again for the link. I installed the modified version of the device handler. Once I did that the sensor connected without issue. I am able to manually turn the light on and have set the default values so it functions like a normal flood light. I am looking forward to setting up a few automations now that things appear to be functioning. I submitted a help ticket on this but have not received a response from HomeSeer. So far I am not impressed with their support.

Hi JimHorlacher. Thanks for the info. What changes did you make to the “modified version” of the code?

Any word if there will be an update to their new Gen2 of this sensor?
The new sensor (G2) has 3 new updates.
-Adjustable motion sensor
-Increase Lux sensor
-Temperature sensor
We have tested 2 already and the addition of a temp sensor is very welcome.

Hey Jim, what modified version did you use ?? My FLS100+ G1 just started messing up during a Zwave repair and there’s no official code to work with Smarth Things “new app” ???

I used this code below:


  • HomeSeer HS-FLS100+

Has anyone had success switching this device into “Z-wave only” mode (Setting parameter 5 to "0)? In this mode, the PIR will not directly turn on the switch, but only report via Z-wave (so the controller can decide what to do).

I implemented this device in Home Assistant, but couldn’t get this part to work, as reported in the HA forum and also in the Hubitat forum.

Any info will be appreciated!

Update: I solved my issue as reported on the linked Home Assistant web page.