Homebridge Update

I received an e-mail from Smartthings telling me that the Homebridge integration is placing a higher than aceptable load on their servers. The email had this line in it:

we need you to update the SmartApp and Node JS app to version 0.5.1 or greater

I updated the smart app to 0.5.2, no problem there.
The app running on my Mac, I executed
sudo npm update -g homebridge

When it was done, it said:

I tried running the update command again and it did not apply further updates.

The smartapp now says 0.5.2, so I know that is updated, how do I get a higher version of the homebridge app?

Figured it out. I needed to update the smartthings plugin.

I did the Update on my SmartThings account, published.

I ran “npm update homebridge -g” and after it did its thing the last line reads:

C:\Users\Scott Townsend\AppData\Roaming\npm-- homebridge@0.4.16

Not too hip on NPM, though I thought that should be v 0.5.2?

Then updated SmartThings, no output
C:\Users\Scott Townsend\.homebridge>npm update homebridge-smartthing -g

Then Ran homebridge.

It ends in:

[2/16/2017, 6:59:29 PM] Homebridge is running on port 51826.

Nothing about Direct Connect Is Listening & Communication Established?