[RELEASE] Homebridge SmartThings v2.0

No it’s Homebridge not recognizing the update. I’ve gone through the process three times now and no matter what still says update available afterwards. As you can see I’m on 2.3.3.

Restarted my QNAP with Homebridge in a container and got the following error:

Homebridge is running on port 51826.
[5/21/2020, 10:43:15 AM] Error: Invalid IV length
at Cipheriv.createCipherBase (internal/crypto/cipher.js:79:18)
at Cipheriv.createCipherWithIV (internal/crypto/cipher.js:115:20)
at new Cipheriv (internal/crypto/cipher.js:217:22)
at Object.createCipheriv (crypto.js:109:10)
at Object.chacha20_poly1305_encryptAndSeal (/usr/local/lib/node_modules/homebridge/node_modules/hap-nodejs/src/lib/util/hapCrypto.ts:90:25)
at HAPServer._this._handlePairVerifyStepOne (/usr/local/lib/node_modules/homebridge/node_modules/hap-nodejs/src/lib/HAPServer.ts:553:33)
at HAPServer._this._handlePairVerify (/usr/local/lib/node_modules/homebridge/node_modules/hap-nodejs/src/lib/HAPServer.ts:515:12)
at IncomingMessage. (/usr/local/lib/node_modules/homebridge/node_modules/hap-nodejs/src/lib/HAPServer.ts:280:24)
at IncomingMessage.emit (events.js:198:13)
at IncomingMessage.EventEmitter.emit (domain.js:448:20)

This is not an error caused by the ST plugin, it’s an issue with the Hap-nodejs module that’s part of homebridge. I don’t personally run docker so I can’t explain why you are seeing the errors.

New User here…

I installed Homebridge on a Windows 10 machine I run as a server. All seems good. Installed the ST plug-in, added everything on the ST side. Config seems OK. I can add devices and get them to show up in Home on my iPhone.
Then, shortly, everything goes to No Response.
I cleared everything, repeated, and same issue.
All on the local network. I’m flummoxed.

Thanks. My homebridge setup is configured to update homebridge and plugins upon a restart and the new version was incompatible with the version of node.js on my docker container. Had to build a new one and it’s resolved.

1 Like

Plugin Change Notice

I’m about to make things slightly more confusing but simpler in the end :slight_smile:

In an effort to simplify the discovery and maintenance of the SmartThings plugin for Homebridge I wanted to consolidate the available packages in NPM.
So I reached out to @pdlove who was the owner of the homebridge-smartthings plugin to get access to the GitHub repository and NPM package, and he quickly relinquished control to me.
I then updated the repository and package to the latest version to match that of my homebridge-smartthings-v2 plugin code.

Once I updated the repository and plug I then submitted the homebridge-smartthings plugin for review to become a verified homebridge plugin, and as of this morning it’s officially verified and will become the plugin I maintain going forward.
I’m going to removing the homebridge-smartthings-tonesto7 and homebridge-smartthings-v2 packages from node package manager so they are no longer searchable and archiving the GitHub repos.

How will this affect plugin updates?

If you are already running my v2 plugin please do the following:

  • Install the homebridge-smartthings plugin
  • Remove the homebridge-smartthings-v2 (Make sure the Remove Configuration option is not checked if using the WebUI to manage your plugins)
  • Just restart Homebridge and it will use the existing configuration file from the v2 plugin.

If you are using the existing homebridge-smartthings or homebridge-smartthings-tonesto7 you will need to start over which will remove your ST devices from HomeKit and add them as new devices.

6 Likes

Do we need to change the platform block when switching over to the new plugin?

nope i left it the same for now… I don’t want to make to many changes :slight_smile:

Great. Thanks. Just switched over without issue.

1 Like

Same here. Easy transition. Thanks.

Congrats to the verification - good work!

(1) OK… I did break my installation when trying to update because some of my other components were outdated. For those who need to start over, the documentation for installing homebridge has become so much better and more convenient. This is a really good step-by-step description for different kinds of platforms now. It only took a total of ~15 min to be back online on a raspberry pi. Keep your existing congig.json file for the id and token of your SmartThings plugin.

(2) There is a " Wyze Connected Home" plugin now that lets you integrate bulb, plug, contact and motion sensors. They are dirt cheap (if you have a cam) and especially the motion sensor is super small.

2 Likes

@tonesto7 do we remove the old plugin before or after we restart? I’m just wanting to make the config carries over.

@tonesto7 here’s another one for you. Gone through this process twice and perhaps it’s user error. Tried installing plugin and goes through entire process and after its complete and says it’s installed it doesn’t actually show as being installed.

image

Does this plugin cover the camera as well and if so can you use original firmware or does it have to be changed?

The " Wyze Connected Home" plugin does not work for the cameras. There is another older one but that is no longer supported.

For the camera you will need to install something like this plugin and install the RTSP firmware on your camera. I have not tried this though,


So I’m still unable to install new plugin or update old one. Here’s my next question. If I were to remove what I’ve got and install either the new one or even the old one again in the event I still can’t new one to install could I just copy and paste the entire config back in? You said the block stays the same right @tonesto7?

The new process to install the new Homebridge is much simpler. When you install the Smartthings plugin the interface will ask you for app ID and token and create the block for you. For other plugins you can just edit and drop the blocks in the homebridge interface now.

Just want to say thanks, installed and tested with a few devices, everything is working fine so far. I like the SmartApp installer process, seems like a great idea.
The only strange thing for me was that when adding the homebridge to the Apple Home app it didn’t carry over the rooms, but I just created them again as I don’t have that many.

I have been trying to get the Homebridge app loaded into smartthings. I was able to get the ST-Community-Installer into the app. but when I go and try to install the homebrdge app it just hangs at Analyzing Repos? did not know if anyone had any ideas on how to fix it?

I had a bit of a nightmare updating with Hoobs - for some reason when I looked for the SmartThings-Homebridge plugin it was showing a really old version (see screenshot below of search result showing the commit date as 2017). Thinking it was the old version, and the Hoobs GUI wasn’t picking up the new version I manually installed using NPM and then altered the Hoobs Config file to point to that. It was then when I realised that the 2017 commit date was a UI error as the version number was the most recent commit.

It still shows the 2017 commit date in my Plugins list, but it is the newer version. Unfortunately I’ve now got to go and re-add all 101 sensors to HomeKit as they’ve reverted back to ‘Default Room’ and lost all their custom attributes.

Hopefully this is helpful for anyone using Hoobs - ignore the 2017 commit date in the Plugins search result, it is actually is the newest version.

Thanks for keeping this update and all your hard work, it’s really appreciated :slight_smile: