Hive Connect not Working

I have had 2 Factor Authentication enabled in the Hive app, removed it and now its all working :slight_smile:

Hi, I’ve followed the tip to change line 1253, but I get a network error when smartthings app tries to add any device other than the heating. I found this in the logs:

446d4670-766a-49a4-a534-23a068f91f6f 23:11:12: error Device type ‘Hive Active Plug’ in namespace ‘alyc100’ not found. @line 1168 (doCall)

Well I thought it was fixed by making this change but its not. After much messing around I managed to screw the app into the ground and now I cant remove it to start again. (Given ST support is less than useless doubtful I’ll get any help from them to remove the old app much before 2021) So I deleted the code from the old app and then created a new app. This allowed me to start again but still its not playing and I now get an error saying Something went wrong. Please try to install the smart app again… Which is just what I’ve done !!

After much removing and readding, and various fiddling, and at one point hot water working but heating not, it’s now working. Not really sure what fixed it. I did notice that in IDE under locations, it had my wife’s email address instead of mine:
And when I went into “edit” it listed my email address twice so I selected the 2nd one.
Not sure if that was actually the issue though but definitely some weirdness in SmartThings for me.

Only have Hive heating. I changed ‘global’ to ‘cognito’, saved and re-published. Had to use the old App to re-authenticate. Didn’t start up straight away, but I could change the Hive thermostat. Gave it ten minutes and now everything is back to normal. Thanks guys, you are all amazing!

Yeah, it won’t work with 2FA, I saw that in the HA forums too

That looks to me like you are trying to add an active plug but the device handler isn’t installed. Even if you don’t have any active plugs, you could try installing their device handler to see if that error stops.

did you go into the smart app and ‘select all’ then delete ? I think I’d try removing the smart app entirely (and work through ST complaining it’s in use by a user.)


Yes use ctrl A and then deleted all the code but still the app wont go, before that I zeroed out all the settings in the app as well… still no good usual cannot remove as in use by another user error. I also have another app that I cant remove and an orphan device so I logged a call with ST to ask them to remove.

decided to ditch Hive but I still need the app to allow the heating and hot water devices to be shown as devices in ST as I use Actiontiles dashboards to display those tiles.

So once ST remove the old stuff I will try a new setup of Hive Connect just for that.

Thank you all for doing the hard work for me! I’ve updated the authentication URL and published to GitHub.

1 Like

Now resolved

Thank you for looking at it but I stil get an error that says Something went wrong please try to reinstall the app. I tried a clean install and that didnt work either. Any ideas?

Worked when I updated IDE but then stopped again. Trying to reenter credentials is giving a 400 error but then seemed to work. I will see if it keeps going this time.

After issues with two different log in errors I’ve deleted and pasted the updated github code (thanks for providing that) … and i can now log in and see the TRVs in the Hive Connect smartapp in ST but only the main thermostat shows up… none of the actual TRVs show up in the ST devices list. Any idea why or how to fix?

Update … I removed all the device handlers and any no longer used apps … one of which was hive related.

Also removed any ifttt and action tiles connections to the hive devices and finally I was able to remove the Hive connect app.
Left it a while then did a fresh install but only used the hot water and heating device handlers and this time it all worked and as for approx 48 hours now.

Reinstated the ifttt and action tiles connections and so far all look s well.

Hopefully nobody else as this problem but if they do try the steps I had to do.

FYI I updated my version of this to now have the new Auth URL (and a bit of code tidy up). thanks

I found that if you remove the group (e.g. room) from each Hive device in the ST API, they then re-appear on the ST devices list in the new ST app and can the be re-assigned rooms. (Thanks to everyone who worked on Hive Integration)

I just had 2FA forced on me when I changed phones and installed the hive app and can’t seem to turn it off. How did you achieve this?
was it Menu > Account > My Details > Two factor authentication as that appears to have been removed :frowning:

I was looking on the hive webpage control panel not my phone, I am an idiot.

1 Like

Am I alone in having lost connectivity between Hive and ST this morning? Authentication error seems to have returned between ST and Hive.



Reading the HomeAssistant forums it seems Hive have moved the API goal posts again