Heiman ZIGBEE leak detector

As all Samsung leak dectectors are on back order, I bought a zigbee dectector. The 2nd generation hub finds it okay and lablels it “THING”, but whan I click it says device not available. I tried this at my office location also. That hub finds it also, labels it “thing” but also says device not available.
How do I make device available?

Device not available is SmartThings for ‘I have no clue what this is’ You need to tell it.

Login to the SmartThings IDE at: https://account.smartthings.com
At the top find Devices - click it.
Scroll down until you see your device, click it.
In the new window, click EDIT
In the Edit Device window find Type (dropdown)
Pick the correct device type In this case if you know exactly what manufacturer and device you have you can likely search the forum for a custom one if none of those work.

1 Like

I have done that , but app still says not available. Thinking it was confilcting with 2.4gz wifi, but it happened with 2nd hub also. I can assign it as anything but as the app can not find it, I get nothing. I put water across leads, the device lights up, but app picks up nothing save to say device is offline when I check

Doubtful. More likely, It would not have joined the network at all if there were signal issues.

It matters exactly which DTH you pick, if it’s not correct, it won’t work, device not available which device type did you pick. EXACTLY what manufacturer and model device is it?

1 Like

Thank you. You are correct. I have no idea what model or manufacturer. I tried but could not complete the form to add device. This was just an Amazon zigbee that came form China. No identifying information.

I added below. Reset up device but it just gives my a cloud with a line through it when it checks status. No tidea how to tie the code I put in from my PC to the install via cell phone. /**


  • Copyright 2020 JOHN SYKAS

  • Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except

  • in compliance with the License. You may obtain a copy of the License at:

  •  http://www.apache.org/licenses/LICENSE-2.0
  • Unless required by applicable law or agreed to in writing, software distributed under the License is distributed

  • on an “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License

  • for the specific language governing permissions and limitations under the License.
    metadata {
    definition (name: “DEVICE HANDLER ONE”, namespace: “jsykas”, author: “JOHN SYKAS”, cstHandler: true) {
    capability “Water Sensor”

    simulator {
    // TODO: define status and reply messages here

    tiles {
    // TODO: define your main and details tiles here

// parse events into attributes
def parse(String description) {
log.debug “Parsing ‘${description}’”
// TODO: handle ‘water’ attribute


do you have a picture - top and bottom of the device please.

You’re mostly likely going to need to assign the Type in the IDE as “Smartsense Moisture Sensor”

1 Like

I am getting there. It works on any Zigbee I chose, ie switch, smke dectector, bu there is no drop down for Zigbee leak dectector. I chose “smoke” and when I put my wet finger on it, my phoen sasy smke detected. Wonder why there is no zigbee choice for water sensor? * Last Hop LQI: 255

  • Last Hop RSSI: -51
  • Received Messages From Device: 9
  • Received Messages From Device (Duplicates): 0
  • Messages Transmitted to Device: 12
  • Messages Transmitted to Device (Failures): 0
  • Updated Time: 2020-12-04 1:29 PM EST
    Data * application: 15
  • endpointId: 01
  • manufacturer: HEIMAN
  • model: WaterSensor-EF-3.0
  • zigbeeNodeType: SLEEPY_END_DEVICE
    Raw Description 01 0104 0402 00 05 0000 0001 0003 0500 0B05 01 0019

Yes, that did ii. No listing under Zigbee, but Smartsense Moiture Sensor worked. Thank yo Nathan & Jimmy for helping me. I learned a lot

1 Like

That’s actually a fairly popular budget brand in the community. glad you got it working. :sunglasses:

Most people seem to use the following DTH: SmartSense Moisture Sensor. Is that what you ended up with?

Yes, that is what I ended up with. The link from the PC was great as I could not find this on the phone app. Frustration is worth when I learn new things. THANK YOU

1 Like

Again, Thank you so much. I could not have firgured this out on my own

1 Like