Groovy Device Migration Complete

We are proud to announce that we have finished the migration process for Groovy-based devices on the SmartThings platform. Over the next few weeks, we will continue cleaning up any lingering Groovy integrations that could not be migrated.

Once this final cleanup is done, we will post here to confirm that the Groovy Device Type Handler and SmartApp transition is complete.

We thank you for your patience and please let us know if you notice any abnormal activity on your account related to this migration.


This is excellent. I can see that the need for an automatic and largely transparent migration process has created a considerable amount of work. I don’t think it is fully appreciated that there is a big difference between this and simply deleting and reinstalling devices.

I think there may be quite a bit of ‘snagging’ to do. Things like devices that aren’t being reliably detected as online when working correctly, or incorrect battery handling, in some cases with the problems dating from day one. Despite the best and greatly appreciated efforts of the developer support team we’ve never really had a effective and practical way to communicate these issues so we haven’t any idea which are known about.


Does this mean @RBoy LUM will be available soon ?

Thanks to everyone who made this happen with a special shout-out to @nayelyz for being the face of the developers to those of us in the user community.

My SmartThings deployment is on the small and simple side. I manually migrated my two Peanut Plugs to @csstup’s driver and replaced the virtual switches and dimmers with ones created by @TAustin’s virtual device creator.

But the remaining 90% of my devices were automatically migrated with no issues.

Well done!


Kudos to the team! While I realize not everyone transitioned smoothly, for me it was almost transparent. Thank you.


Sigh, 2 days ago I get the heart stopping moment of ‘you garage door is open’. First gen Smartthings Multisensor that Samsung has decided isnt worth trying to work with an edge driver. Tried Mariano_Colmenarejo’s driver cause some places it sounds like it would work some places said it wouldnt. No good, tilt is dead. Sad that they decided to drop the first sensor that they put out and still worked for everyone using it.

So spent a few hours trying to delete and re-add it, nothing I could do could get it to pair again for some reason. Guess that sensor is going in the trash. The only thing I have that used AAAA batteries so thats good to be gone I guess. Then another couple hours trying to figure out a way to make a standard open/close sensor work on a normal garage door. Finally ended up with the sensor on the overhead rail for the opener and the magnet on the ‘trolley’. Works but annoying when simple tilt sensor worked well. The other solution I saw was using a hinge, put the sensor on the hinge and hinge on the top panel of door with magnet below the sensor. When the door opens and the hinge swings down cause of weight of the sensor it opens the contact. But the ‘trolley’ is working for now.

That was the last device out of like 120 devices and had hoped by now they would have figured out a way to support it. More ammo for my pros/cons of why i need to finally jump ship to home assistant

@KevinH I currently have 3 first gen contact sensors running (one on garage door using tilt) on the stock driver - v2 hub - with no issues:



Thats not a ‘1st gen’. This is a 1st gen, box even says 2013 for copyright on the back

When migrated it had the default edge driver. It didnt offer garage door mode. I added Marino’s driver and tried to switch to it and it said not compatible when I did it in the advanced web portal. I then deleted the device…and now I cant get it to pair again lol. Oh well guess it will just go in the trash. Yea 10 years old possible device, still the door and window sensors of my alarm (which are zwave but an actual long term device) still work and they’ve been in place since 2007.


@KevinH My apologies, the gens go back further than I thought! :grinning:

1 Like

EDIT: the not running locally part of this was resolved by creating identical new routines for each one that uses the sensor.

Where should we go to report (ask for help with) things that seem to be partly migrated. In my case this is an Inovelli 4 in 1 sensor (LZW60). It still works (stuff happens as expected when brightness changes or motion is detected) and it is apparently migrated (because the vertical ellipsis menu in the app has “Driver” in the menu, which then shows it is "Z-Wave Sensor), but the routines that query it still don’t run locally (I have verified this device is what is causing that), and for the last several weeks whenever I go to the device page it briefly pops up “this device hasn’t updated all of its status information yet”.

I have a couple 4 in 1’s that are working fine with routines running locally. So it’s probably your sensor, not a systemic issue. You may wish to start a new thread here, or better yet, at

Share a screenshot of your routine, maybe we can see what is causing to run in the cloud.

How do I report Zwave device malfunction? My Fibaro used to work fine before with the Groovy driver and stopped to switch with the edge.

The routine is very simple. Here’s one that uses the sensor to turn off the address light and doesn’t run locally:

Here’s another the just uses time to turn off the same light that does run locally:

At one point anything with luminance got kicked to the cloud because it required a conversion calculation, but I don’t know if that’s still true. :thinking:

After grabbing screenshots I thought to myself “maybe I should try re-creating the routine”. Sure enough that fixed it.


Hi @veonua please can you give more information about your device and the problem?
if you know the fingerprint it can help me to check it. :saluting_face:

If your device just converted, editing the routine should force it to re-evaluate the cloud/local status - could be as simple as changing the routine name. I know you’ve already fixed that one but if you have others or for anyone else looking, might save some rebuilding time.


It appears my original SmartThings SmartSense motion sensor (the one with the mini-USB port) was migrated on 8/7… at least that is the last day it reported motion.

In the SmartThings app it appears “connected”, and the current driver is named “Zigbee Thing” with no results found when trying to “Select Different Driver”.

So are these sensors now trash? Or is there a way to get them working again?

Take a look at this thread Scott