Graber Virtualcord roller shades (Zerbrashades)

Hi All,

I am now the proud owner of 6 Zebrablinds Rollershades. So far, pretty happy (They can be persnickety to set up, but straightforward). I do have some questions…

  1. Is there a custom device handler for this? I have checked the posts out there, but there are literally hundreds of messages and nothing obvious. Ideally, something that allows them to be partially opened, or at least issue the Home/Favorite command.

  2. I am having a very weird issue, and Zebrablinds/Distributer tech support is trying to help, but it appears to be SmartThings specific.

When I use the manual button on the shades, or a connected graber remote… there is no issue. The shades work perfectly.

However, when I issue an ON or OFF command from ST (either directly, through a group scene, or via an Alexa-created grouping), typically one or two of the shades will move EXTREMELY slowly, stop at some random midpoint, and then the LED will give me a slow red for about 1-2 sec. Sometimes they all work. I’d say they all work perfectly about 1/5 of the time.

According to tech support, this indicates ~<20% battery. The batteries are brand new- and if I then walk over and press the button manually, they work fine. Evidently they recommend lithium batteries, so those are ordered. But like I said, this happens but they immediately work via manual press.

So this ONLY happens on the ST commands. Never happened on a manual press. It can happen as part of a group (we usually work all 6 at once), or it can happen with an individual ST on/off command. As far as I can recall, it’s happened to all of the shades at least 1-2, but there are two specifically that seem to be most affected.



or try here

Thank you. Looks like this works well… although I am not getting battery levels (I will live).

Ah. Wait. I am getting battery levels… I have one misbehaving, but I think it’s a different issue.

Any idea what is different about this DH that seems to fix the weird slow open/close issue?

One more time… looks like the issue of the shades stopping in the middle of travel is still an issue.

I will try the lithium batteries when they come today, but each of the shades still occasionally grinds to a halt in the middle of a ST initiated motion with a red blink (indicates low batter), but then is immediately OK with button or remote presses.

Note: Now that I have the new DH in place and it’s communicating, I see that the battery levels are all over the place. Despite them all being new (two weeks old), and used pretty much collectively, the battery levels are reported as 84/64/83/35/67/84%. There’s no correlation between which shades stall out and battery.

Do you have the issue when controlling them individually, or as a group?

Also if controlling individually, directly from the ST app or through alexa? Also if it’s grinding to a halt does the remote work?

I have not seen them halt when pressing the graber remote buttons or the button on the shade itself.

I have two “groups” set up. One as a scene on the SmartThings App, and one as a group created via the Alexa app, so we can easily initiate with voice). The halts definitely happen via both of these group initiations.

They have definitely happened when controlling an individual shade via Alexa (“Alexa turn on Shade 3”).

I am pretty sure that halts have happened when controlling shades individually via the ST app, but I don’t do that often.

Also, after a halt, sometimes the remote doesn’t work again until I use the button on the shade, but usually it works via the graber remote right away.

Do you know what codes/commands the remotes send to the shades? Do they possibly differ from the custom DH?

More Info…

The Energizer AA Lithium batteries came today. Swapped them in, and waited a few minutes to make sure it had reconnected to the network.

Check the ST Device page: The battery was now showing 100%. So that’s good.

Opened the shade with the ST app: Opened a bit and stalled.

Note: The shade would now no longer respond to the ST app commands- however the % open updated to 16%, which seemed to be about right.

So, I used the dedicated graber remote, and it responded perfectly. Cycled several times open/closed.

After about 3-4 cycles, I used the ST app to open it. Same thing: Stalled out with a red flash at about 20%.

The graber remote worked fine. But again, no control from ST.

After playing with it with the graber remote again, for several cycles, the ST app started to work again. And then I tried an Alexa call (“Alexa turn on shade 2”) and it didn’t move, and no more ST commands worked.

However, the graber remote continues to work fine.

Is there any documentation on the graber remote: Is it sending standard Zwave messages? Do we know what codes it is sending? I haven’t looked at the DH, but is the DH sending open/close messages, or is it calculating remaining travel? So that it might be out of position?

All the others appear to be working with normal AA batteries right now, it’s just this one that’s giving me trouble. That’s not to say I trust that the others won’t stall out at some point.

OK. At this point I am at a loss.

The shade works perfectly with the 2-button graber remote.

Both the remote and the shade were added to ST (Shade to ST first, then remote to ST, then remote to shade).

Both the shade and the remote report status to ST. So when I open with the remote, the %-open updates to ST within a minute or so. I can see events in the “Recently” tab and the app Notifications.

I can see button presses in the remote DH screen in ST. So that’s talking to ST.

However, the shade does not respond to ST commands at all. It did a few times yesterday, but not now. The other 5 shades in the room work perfectly.

I have removed, reset and re-added the shade/remote several times.

Can you send an email to with the order number and just link this thread to it. We need to take it up with Graber and see whats going on. I’ll also be pming you with some additional troubleshooting details.