Google Home stopped recognizing some devices


#1

Why is Google Home able to turn on/off the light named “recessed” in the room named “living room” from a routine, but with voice commands it says it doesn’t understand or it needs to be setup?

The activity page shows that it did understand the correct words. I tried renaming both switch and room, but it didn’t help.

Here is a few details.

Two weeks ago I added the first smart switch to SmartThings and linked it to Google Home. It worked well until today, with both voice commands and routines.

Today I added one more smart switch, assigned it to the living room both in SmartThings and in Google Home, renamed both switches in both SmartThings and Google Home, and now Google Home doesn’t recognize neither switch.

I unlinked and re linked the SmartThings hub, but nothing changed.

I checked the routine, I noticed that it had lost the name of the switch, so I added both the switches.

Now the routine is able to turn both the switches on and off, but the voice commands can’t. Here is the content of the last two voice commands directly from the activity page:

Assistant
Said turn on all the lights in the living room
com.google.homeautomation
It looks like those lights haven’t been set up yet. Just open the Google Home app and go to Home Control to add lights.
11:07 PM

Details

Location info

Assistant
Said turn on the recessed lights
Sorry, I don’t understand.
11:06 PM

Details

Location info


#2

I can’t be absolutely sure since there is a chain of events here but I suspect your problem is names.

I suspect that if you asked Google to turn on recessed, you would find that works. The reason you can’t turn on all the lights in the living room is that “recessed”, isn’t a light, it’s a recessed. Google has some quirks when it comes to names but the bottom line is, if you want Google to know it’s a light you need to have a name that indicates it’s a light such as recessed light or recessed lamp.


#3

The good news is you are right. I added “lights” at the end of the name and now it works. :smile:

The bad news is that my wife had suggested the same thing and I told her “yeah, right, like I need to tell Google that a light is a light, Google knows that already!”. Now I need to live with this stain in our marriage. :cry:


#4

I hate it when that happens.


(Tom Guelker) #5

I’ve been married 35+ years and I have been wrong a few times. So has my wife. We admit we aren’t perfect. What we do is when something like this happens, we write on the calendar that day “Tom was wrong” or “Linda was wrong” Turns an embarrassment into a laugh and a reminder to not dismiss anything as a possibility.


(Jeff) #6

I have had Smartthings and Google Home for over a year now and everything has been working great until about amonth ago.

Now all of a sudden lights that used to trigger fine, Google is saying “sorry I don’t know what light you wanted to turn on”. However, if I tell it “Turn all the lights on {or off}” it triggers the light fine. I can even tell it “Turn {room name} on” and it will trigger all the devices in the room. It seems to be isolated to the specific light name (on multiple lights). I am using “light” at the end of the device name. Weird things is some will still trigger by name - like “Turn on closet light” works but “turn on master bedroom light” does not. Nor does “turn on kitchen light”.

Again everything was working fine until a month ago and I did not rename any devices (just added additional ones - up about 70 devices). I can manually trigger via Smartthings no problem as well. I can see the devices in both the Smartthings and Google Home apps as well.

It seems like Google and Smartthings have some issue in the handoff after the most recent updates.

Anyone else having the same problem? Anyone have a solution?


(Bill Ho) #7

I had similar problem previously. I think I just remove and relink ST in Google Home to solve that problem.