Google Home Errors


(Steve Jackson) #1

Anybody using Google Home and receiving “something went wrong” errors over the last couple weeks. I can issue one automation request and then I get the error. Rebooting fixes it but only for a single command then I have to reboot again. I’ve tried most everything I can think of and thought I would throw it out here and see if it’s rare. I didn’t see a ton of info online.


(Rajan Kannan) #2

Yes… I get the message “something went wrong” sometimes. Most of the item it gets resolved by itself. Few times it would not get fixed and i will do a reboot of the device which will fix it. Even i had the same question if this is normal and expected.


(Steve Jackson) #3

We have had one since Christmas and ours only started acting this way within the last 2 weeks. Nothing changed on the Network here, I was in Florida and my wife says that it just quit reliably working.

It’s so bad that the device is completely unusable. I’m hoping Google will resolve it or I guess I’ll cut my losses and either buy an Alexa or just go back to the mini motes. I even tried setting up a brand new Google account tonight and that didn’t fix it. Up until this, I was so happy with the unit I ordered a second one and it was looking forward to setting it up. I did set it up and the new one acts the same way. As soon as I issue a command to smartthings or my Honeywell, the unit is dead. I did find that turning the accessibility tones off and on will bring it back without a reboot. I gave up tonight and will work on it more over the weekend. Maybe Google will have some suggestions?


(Steve Jackson) #4

I found a phone number and talked to a Google Home support person.

It’s a known issue and they have replicated it. They believe it’s affecting a large part of the HA population. They are working on finding the root cause and then a fix.

She said I may hear back from the engineers for additional information. If I do, I’ll pass along anything I find out.


(Justn ) #5

Haven’t had any issues with mine yet.


(Steve Jackson) #6

I hope you don’t. It’s s real pain. I’ve used autovoice, tasker and sharp tools along with @ZebraBlinds tasker profile as a work around for now.

The issue has decreased the WAF. I have to find a thermostat workaround this afternoon. She really likes the “bump the temp 1 degree” option while sitting on the forced air heat vent. LOL


(Chris H) #7

Out of nowhere (no recent app updates, system tweaks, etc), mine got all sorts of wonky for several days a couple of weeks ago… Lighting and thermostat commands that worked fine previously were all suddenly unrecognized. To note, these commands that weren’t tied to IFTTT, so that integration wasn’t to blame.

Then, out of nowhere once again, it all went back to behaving totally normal later that week.

Knock on wood, it’s all been solid since!

Google really likes to do server-side updates, and while that’s great in terms of being nimble, it stinks in terms of transparency.

Plus, it seems like (I have no evidence of this!) they do these server-side updates in waves, and not as a big-bang push to everyone; so at any given time, folks are having different experiences, which makes it harder to figure out what’s going on.

Owning a GH is a bit of an adventure, that’s for sure!


(Steve Jackson) #8

That would explain while someone else on the same software versions of his homes is working while mine isn’t. Based on my phone call I’m sure it’ll get fixed, just a matter of when. Hopefully, sooner than later.

Thanks @Hydro


(Chris H) #9

You’ve probably already done this, but if it’s been awhile since you’ve rebooted your GH, it may be worth a shot…

I’m fairly confident this was just a coincidence, but I had rebooted my router/home network (for unrelated reasons) not too long before I noticed my GH was working normally once again.

Since it’s not too painful to do, maybe a device/network reboot is worth a try? Heck, any port in a storm :slight_smile:

Good luck!


(Steve Jackson) #10

Oh yea. I even did compete resets of the homes. Unlinked and relinked services. Tried different DNS. Tried different Wi-Fi Channels. Lots of reboots. The Home appears to quit communicating because my phone will intercept the commands the Home should take. What’s odd is that turning accessibility tones on/off will bring it back to life without a reboot. Google seemed interested in this finding.


(Justn ) #11

I did notice over the past few days that its “thinking” a lot longer before executing the commands. The little lights at the top swirl for about 5 extra seconds.


(Steve Jackson) #12

No fix yet. Still not working as of this morning. The workaround has at least made it tolerable. In fact, kind of getting used to being able to issue several commands at the same time.

It still needs the fix for the WAF to go back up though. She is very tolerant and is patiently waiting.


(Steve Jackson) #13

Google says they are working on it. Supposedly a Hue update caused the problem. I did learn that just muting/unmuting the Home will also bring it back to life.

We had a power failure while I was gone. I am wondering if the power failure, which caused the home to reboot, has caused my homes to act up while others here are not having issues because their homes have not rebooted.

It must be one heck of an issue for Google to take this long to fix it.


(Steve Jackson) #14

On other forums I’m seeing more people being affected. I called Google again today and was told they were “monitoring” the problem. I replied that “maybe they should fix it instead.” I guess it’s to be expected on a first gen product.


(Chris) #15

I have 3 GH devices, no issues here yet.


(Neil Rao) #16

I too am also seeing this exact same behaviour. GH works fine for all queries and even commands to IFTTT. But, as soon as a smartthings command is issued it completes this command and then locks up. ALL further queries result in “something went wrong” until a reboot of the unit. Hmmm, this is getting very frustrating. Also to note, I’m in the process of setting up HA with smartthings (somewhat of a noob). Anyway, when I had first setup my track Lights in the kitchen, and named them “kitchen lights” then added them to the room “kitchen” it seemed to really throw GH a curve ball, it didn’t like double kitchen- “ok google turn on kitchen kitchen lights”. When I renamed the lights to “track lights” everything calmed down and seemed to be fixed. But now, after adding a few more light switches, all smartthings commands seem to lock up GH. So this started for me about 10 days ago.


(Steve Jackson) #17

@IndyR you don’t have to reboot. You can turn the mic off and then back on and it will unfreeze your Google Home.

No ETA with a fix. You can call and log the issue with Google if you desire. The number is 855-971-9121. It probably won’t help but it’s a quick call, you speak to a person, and at least let’s them know they have another unsatisfied customer.

You are correct about the rooms. Google doesn’t like lights with the room name in the room they are assigned to.

Here is hoping they get this fixed soon. It’s very inconvenient.