Goodnight Automated Routine not Working

I changed the Goodnight routine from manual to trigger at 10pm, but it never works. It’s very simple. It’s merely a time event set to 10pm (all days) and it just shuts off lights and locks doors. That’s it. Is anyone else having this issue? If I temporarily change the time to say 10:15, before the actual time, in order to give it a second chance, that works. So wonky. I’m starting to regret my move back to ST from Hubitat. Several other issues I’ve encountered as well, but I’ll address those separately.


I’ve read several threads where time based routines mis-trigger especially after a power outage on the hub due to a timing offset but it seems odd that it works if you reset the time. Personally, I found the native time trigger to be unreliable so changed all my time triggered routines to use the Aplicaciones Virtuales Mc (Virtual Calendar device). I find it to be much more flexible and reliable. It also has dates and days of the week. While not an answer, this may be a possible solution.

3 Likes

Thanks Terri. Mariano makes everything lol. I’m already running a few of his drivers. Problem is, ST has been a platform for a very long time to be still having simple issues to fix and doing nothing about it. That’s a big reason I left for Hubitat 5 years ago. Plus Rule Machine moved to Hubitat so it was a simple choice since I had been using it and then it’s creator (Bruce) pulled it from ST because ST wouldn’t work with him or something like that. Been a long time since. I can’t believe a simple time of day event is even an issue left unsolved. Thanks again for the info. I must have glossed over this from Mariano, but I can’t say I’d have thought to need such, till your reply

1 Like

I wonder if the issue might be related to switching it from a Manually Run Routine to a Automatic Routine. You may want to try creating a new Automatic Routine and delete the old one.

note: you can use Manually Run Routines within Automatic Routines. I tend to set up Manually Run Routines with groups of devices I control and use them in Routines. Such as “Turn a particular set of lights off at 10pm”. That way, if the Automatic Routine does not fire… I can simply press the Manually Run Routines.

2 Likes

Pretty much what I do, now that you can “call” another local routine and have execution remain local. “At 10PM Every Day” run “Goodnight!”

4 Likes

Hmm…I call locally executable scenes (manual Routines) using both relative time (x before sunset) and explicit time (1am) from other Routines. In both cases, they show as executing in the cloud. I have Wi-Fi hub (Plume) running 47.12.

Scenes only became eligible for local execution fairly recently. It may be that the plume model firmware is not yet updated to support that. :thinking:

1 Like

Ah, I forgot that it was a recent addition. Since the Wi-Fi hubs haven’t seen an update since Jul 2023, that’s likely the reason.

1 Like

Guess I should have mentioned I have V2 hubs! :grinning:

2 Likes

lol. Never would have guessed, accept typical for ST :stuck_out_tongue: weird that if it doesn’t and I advanced the time for a second try - that works

It’s definitely showing it’s local

1 Like

Hi @jkp - That did cross my mind. From all the 4 HA platforms I’ve been on since 2015, stuff like that has come up before. I may switch it back to a manual routine, as you mentioned and trigger it with a normal routine. It also took me a bit to figure out that ST renamed Scenes to Manual Routines. I was wondering where Scenes had gone. Like they’ll mess with renaming things like that, but not work on the every-day issues, like making sure a routine fires properly at X time.

3 Likes

I bet you’re right. Though, I wasn’t running this as a “scene” (manual routine), but based on a set time. So just now when I deleted that Good Night automated Routine, (because after removing the Time trigger, the Manual Push option was ghosted). So now when I went to recreate the Good Night manual Routine, that turned out to be cloud-based vs the automated version which was local execution. [shrug]

I do show the automatic Routine is run locally, as it says Execution Location: Local. However, if I remove the Time trigger (condition), it won’t allow me to change it back to a Manual tap as that option is ghosted. Probably have to delete it

Can’t change Routines on the AWA, they’re read-only.

Ha! just saw that. I saw it before, but forgot. You got me before I could erase that part of my message lol

They call me Quicksdraw McGraw :slight_smile:

1 Like

lol!! Too funny Amigo. :smile:

Well, turning it back into a manual routine (scene) and using an automatic routine to trigger the manual routine at a specific time worked. Silly… but maybe with a firmware update, that’ll change

2 Likes

Keep in mind anything that uses a cloud-based function, like “Send notification to members” (which I have saying “Goodnight, Location” where Location is name of one of our two hubs) forces that Scene/Routine to execute in the cloud!

Actually, what I do is a bit convoluted! I have a Scene (now Manual Routine) called “Good Night!” that simply sets a local virtual switch vNightMode to ON. It can be run manually, called by a time-based routine, or by saying, “Alexa, Goodnight!”

Another Routine called “vNightMode turns ON,” which has a precondition where Location mode is Home, Night, or Evening–to prevent execution when we’re Away–actually does the heavy lifting. It changes Location mode to Night, runs a Scene called “Lights OFF,” and switches another device OFF. It runs locally. In parallel, there’s a Routine called “Notify: Goodnight!” that runs when Location mode changes to Night that calls “Send notification to members.” That routine does not run locally–but we wouldn’t get the notification anyway if the Internet is out, so I don’t care. But all the stuff that runs locally controls stuff that really matters.

You can probably guess what happens in the routine “vNightMode turns OFF” in the morning!

And yes, I’ve added one additional Location mode called “Evening” to complement the modes that come pre-configured. It has other things it does…

3 Likes